CVE-2024-51482 Boolean-based SQL Injection in ZoneMinder v1.37.* <= 1.37.64
Attackers can exploit a boolean-based SQL injection in ZoneMinder to read or modify database contents.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-51482?
CVE-2024-51482 is a critical SQL injection vulnerability in zoneminder, published on 31 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
ZoneMinder is a free, open source closed-circuit television software application. ZoneMinder v1.37.* <= 1.37.64 is vulnerable to boolean-based SQL Injection in function of web/ajax/event.php. This is fixed in 1.37.65.
Weakness: CWE-89
Which versions are affected by CVE-2024-51482?
How do I fix CVE-2024-51482?
No fix has been published for CVE-2024-51482 yet. Limit exposure of the affected software until one is available.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2024-51482 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51482 exists.
Public exploit code: 1 Nuclei template and 9 proofs of concept on GitHub.
Sources
Also known as GHSA-qm8h-3xvf-m7j3, UBUNTU-CVE-2024-51482.