# CVE-2024-51483: changedetection.io Path Traversal vulnerability

> Attackers can read local system files via WebDriver file:// URIs in changedetection.io, requiring the WebDriver feature to be enabled.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Nov 2024
- **Updated:** 1 Nov 2024
- **Also known as:** GHSA-cwgg-57xj-g77r, PYSEC-2026-1240

## What is CVE-2024-51483?

CVE-2024-51483 is a medium-severity path traversal vulnerability in dgtlmoon changedetection.io, published on 1 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

changedetection.io is free, open source web page change detection software. Prior to version 0.47.5, when a WebDriver is used to fetch files, `source:file:///etc/passwd` can be used to retrieve local system files, where the more traditional `file:///etc/passwd` gets blocked. Version 0.47.5 fixes the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-51483?

3 open source packages ship an affected version, including changedetection.io and changedetection-io.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `changedetection.io` | PyPI | All versions | 0.47.5 |
| `changedetection-io` | PyPI | All versions | 0.47.5 |
| `changedetection-io` | PyPI | All versions | 0.47.5 |

## How do I fix CVE-2024-51483?

Upgrade changedetection.io to 0.47.5 or later.

## Is CVE-2024-51483 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51483 exists.

Public exploit code:

- Changedetection.io <= 0.47.4 - Path Traversal (nuclei): http/cves/2024/CVE-2024-51483.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-51483 and fix it if it is affected.

What it is: CVE-2024-51483 is a medium-severity path traversal vulnerability in dgtlmoon changedetection.io, published on 1 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51483 exists.

Affected packages and fixed versions:
- changedetection.io (PyPI): affected all versions; fixed in 0.47.5
- changedetection-io (PyPI): affected all versions; fixed in 0.47.5
- changedetection-io (PyPI): affected all versions; fixed in 0.47.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-51483/ (Markdown: https://insights.sbomify.com/CVE-2024-51483/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-51483
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-51483
- OSV: https://osv.dev/vulnerability/CVE-2024-51483

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-51483/
Summaries are generated and may contain mistakes; the official description above is the record.
