# CVE-2024-51493: API key access in settings without reauthentication in OctoPrint

> Attackers with session access can retrieve or delete API keys without reauthentication, enabling unauthorized API access or workflow disruption in OctoPrint.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Nov 2024
- **Updated:** 5 Nov 2024
- **Also known as:** GHSA-cc6x-8cc7-9953, PYSEC-2024-202

## What is CVE-2024-51493?

CVE-2024-51493 is a medium-severity missing authorization vulnerability in OctoPrint, published on 5 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OctoPrint provides a web interface for controlling consumer 3D printers. OctoPrint versions up until and including 1.10.2 contain a vulnerability that allows an attacker that has gained temporary control over an authenticated victim's OctoPrint browser session to retrieve/recreate/delete the user's or - if the victim has admin permissions - the global API key without having to reauthenticate by re-entering the user account's password. An attacker could use a stolen API key to access OctoPrint through its API, or disrupt workflows depending on the API key they deleted. This vulnerability will be patched in version 1.10.3 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-620 (Unverified Password Change)

## Which versions are affected by CVE-2024-51493?

3 open source packages ship an affected version, including octoprint and OctoPrint. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `octoprint` | PyPI | All versions | 1.10.3 |
| `octoprint` | PyPI | All versions | 1.10.3 |
| `OctoPrint` | PyPI | All versions | 1.10.3 |

Products: Octoprint Octoprint.

## How do I fix CVE-2024-51493?

Upgrade octoprint to 1.10.3 or later.

## Is CVE-2024-51493 being exploited?

There is no known exploitation of CVE-2024-51493 in the wild and no public exploit code.

## Other vulnerabilities in OctoPrint

- [CVE-2018-16710](https://insights.sbomify.com/CVE-2018-16710/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-58180](https://insights.sbomify.com/CVE-2025-58180/): OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload (high 7.5)
- [CVE-2022-1430](https://insights.sbomify.com/CVE-2022-1430/): Cross-site Scripting (XSS) - DOM in octoprint/octoprint (high 7.5)
- [CVE-2022-1432](https://insights.sbomify.com/CVE-2022-1432/): Cross-site Scripting (XSS) - Generic in octoprint/octoprint (high 7.5)
- [CVE-2024-32977](https://insights.sbomify.com/CVE-2024-32977/): OctoPrint Authentication Bypass via X-Forwarded-For Header when autologinLocal is enabled (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-51493 and fix it if it is affected.

What it is: CVE-2024-51493 is a medium-severity missing authorization vulnerability in OctoPrint, published on 5 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-51493 in the wild and no public exploit code.

Affected packages and fixed versions:
- octoprint (PyPI): affected all versions; fixed in 1.10.3
- octoprint (PyPI): affected all versions; fixed in 1.10.3
- OctoPrint (PyPI): affected all versions; fixed in 1.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-51493/ (Markdown: https://insights.sbomify.com/CVE-2024-51493/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-51493
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-51493
- OSV: https://osv.dev/vulnerability/CVE-2024-51493

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-51493/
Summaries are generated and may contain mistakes; the official description above is the record.
