{"answers":{"affected":"2 open source packages ship an affected version, including loona-hpack.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51502 exists.","fix":"Upgrade loona-hpack to 0.4.3 or later.","what":"CVE-2024-51502 is a medium-severity denial of service vulnerability in bearcove loona, published on 4 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-51502 and fix it if it is affected.\n\nWhat it is: CVE-2024-51502 is a medium-severity denial of service vulnerability in bearcove loona, published on 4 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51502 exists.\n\nAffected packages and fixed versions:\n- loona-hpack (crates.io): affected all versions; fixed in 0.4.3\n- loona-hpack (crates.io): affected all versions; fixed in 0.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-51502/ (Markdown: https://insights.sbomify.com/CVE-2024-51502/index.md)","id":"CVE-2024-51502","markdown":"https://insights.sbomify.com/CVE-2024-51502/index.md","name":"CVE-2024-51502","record":{"aliases":["GHSA-7vm6-qwh5-9x44"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust HTTP library","requires_auth":"low_privilege","summary":"Attackers can cause a panic in the loona-hpack library by sending untrusted input, leading to denial of service.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-755","name":"Improper Handling of Exceptional Conditions"}],"description":"loona is an experimental, HTTP/1.1 and HTTP/2 implementation in Rust on top of io-uring. `loona-hpack` suffers from the same vulnerability as the original `hpack` as documented in issue #11. All users who try to decode untrusted input using the Decoder are vulnerable to this exploit. This issue has been addressed in release version 0.4.3. All users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Panic Vulnerability in loona-hpack","id":"CVE-2024-51502","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Command injection in Trend Micro Deep Security","id":"CVE-2024-51503"},"packages":[{"ecosystem":"crates.io","fixed":["0.4.3"],"introduced":["0"],"last_affected":[],"package":"loona-hpack","purl":null,"source":"GHSA-7vm6-qwh5-9x44"},{"ecosystem":"crates.io","fixed":["0.4.3"],"introduced":["0"],"last_affected":[],"package":"loona-hpack","purl":"pkg:cargo/loona-hpack","source":"GHSA-7vm6-qwh5-9x44"}],"prev":{"headline":"CRLF injection in Refit's [Header], [HeaderCollection] and [Authorize] attributes","id":"CVE-2024-51501"},"products":["loona"],"published":"2024-11-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-21","vendors":["bearcove"]},"summary":"Attackers can cause a panic in the loona-hpack library by sending untrusted input, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2024-51502/"}