# CVE-2024-51502: Panic Vulnerability in loona-hpack

> Attackers can cause a panic in the loona-hpack library by sending untrusted input, leading to denial of service.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Nov 2024
- **Updated:** 21 Nov 2024
- **Also known as:** GHSA-7vm6-qwh5-9x44

## What is CVE-2024-51502?

CVE-2024-51502 is a medium-severity denial of service vulnerability in bearcove loona, published on 4 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

loona is an experimental, HTTP/1.1 and HTTP/2 implementation in Rust on top of io-uring. `loona-hpack` suffers from the same vulnerability as the original `hpack` as documented in issue #11. All users who try to decode untrusted input using the Decoder are vulnerable to this exploit. This issue has been addressed in release version 0.4.3. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2024-51502?

2 open source packages ship an affected version, including loona-hpack.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `loona-hpack` | crates.io | All versions | 0.4.3 |
| `loona-hpack` | crates.io | All versions | 0.4.3 |

## How do I fix CVE-2024-51502?

Upgrade loona-hpack to 0.4.3 or later.

## Is CVE-2024-51502 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51502 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-51502 and fix it if it is affected.

What it is: CVE-2024-51502 is a medium-severity denial of service vulnerability in bearcove loona, published on 4 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51502 exists.

Affected packages and fixed versions:
- loona-hpack (crates.io): affected all versions; fixed in 0.4.3
- loona-hpack (crates.io): affected all versions; fixed in 0.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-51502/ (Markdown: https://insights.sbomify.com/CVE-2024-51502/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-51502
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-51502
- OSV: https://osv.dev/vulnerability/CVE-2024-51502

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-51502/
Summaries are generated and may contain mistakes; the official description above is the record.
