{"answers":{"affected":"It affects 1 product.","exploited":"Yes. Attackers have exploited CVE-2024-51567 in the wild since at least 7 Nov 2024, including in ransomware campaigns.","fix":"No fix has been published for CVE-2024-51567 yet. Limit exposure of the affected software until one is available. US federal agencies must fix it by 28 Nov 2024.","what":"CVE-2024-51567 is a critical authentication bypass vulnerability in n/a, published on 29 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-51567 and fix it if it is affected.\n\nWhat it is: CVE-2024-51567 is a critical authentication bypass vulnerability in n/a, published on 29 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: Yes. Attackers have exploited CVE-2024-51567 in the wild since at least 7 Nov 2024, including in ransomware campaigns.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-51567/ (Markdown: https://insights.sbomify.com/CVE-2024-51567/index.md)","id":"CVE-2024-51567","markdown":"https://insights.sbomify.com/CVE-2024-51567/index.md","name":"CVE-2024-51567","record":{"aliases":["GHSA-w6g2-qqv5-83qj"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"CyberPanel web hosting","requires_auth":"none","summary":"Remote attackers can bypass authentication and execute arbitrary commands in CyberPanel by exploiting a middleware flaw and shell metacharacters.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cyberpanel","vendor":"cyberpanel"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AC:L/AV:N/A:H/C:H/I:H/PR:N/S:C/UI:N","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2024-10-27","github_poc":3,"max_poc_stars":5,"metasploit":1,"nuclei":1,"refs":[{"date":"2024-10-31T21:55:57Z","kind":"github_poc","ref":"https://github.com/ajayalf/CVE-2024-51567","stars":5,"title":"CVE-2024-51567 is a Python PoC exploit targeting an RCE vulnerability in CyberPanel v2.3.6’s upgrademysqlstatus endpoint, bypassing CSRF protections."},{"date":"2024-11-07T13:52:37Z","kind":"github_poc","ref":"https://github.com/thehash007/CVE-2024-51567-RCE-EXPLOIT","stars":1,"title":"cbyerpanel rce exploit"},{"date":"2024-10-27","kind":"metasploit","ref":"exploit/unix/webapp/cyberpanel_preauth_rce_multi_cve","stars":null,"title":"CyberPanel Multi CVE Pre-auth RCE"},{"date":"2025-08-07T02:15:49Z","kind":"github_poc","ref":"https://github.com/KKDT12138/cve-2024-51567-poc","stars":0,"title":"CVE-2024-51567 is a Python PoC exploit targeting an RCE vulnerability in CyberPanel v2.3.6’s upgrademysqlstatus endpoint, bypassing CSRF protections."},{"date":null,"kind":"nuclei","ref":"http/cves/2024/CVE-2024-51567.yaml","stars":null,"title":"CyberPanel v2.3.6 Pre-Auth Remote Code Execution"}],"tier":"exploited"},"has_fix":false,"headline":"CyberPanel Incorrect Default Permissions","id":"CVE-2024-51567","indexable":true,"kev":{"dateAdded":"2024-11-07","dueDate":"2024-11-28","knownRansomwareCampaignUse":"Known","product":"CyberPanel","requiredAction":"Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.","vendorProject":"CyberPersons","vulnerabilityName":"CyberPanel Incorrect Default Permissions Vulnerability"},"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":0,"n_references":7,"next":{"headline":"Command injection in n/a","id":"CVE-2024-51568"},"packages":[],"prev":{"headline":"bhyve(8) NVMe driver to guest-induced infinite loops.","id":"CVE-2024-51566"},"products":["n/a"],"published":"2024-10-29","related":[{"cvss_score":10,"headline":"CyberPanel Incorrect Default Permissions","id":"CVE-2024-51378","kev_date_added":"2024-12-04","published":"2024-10-29"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2024-51568","kev_date_added":null,"published":"2024-10-29"},{"cvss_score":8.8,"headline":"CyberPanel \u003c 2.4.5 Unauthenticated API Access via AI Scanner Endpoints","id":"CVE-2026-41473","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":8.8,"headline":"Command injection in n/a","id":"CVE-2024-53376","kev_date_added":null,"published":"2024-12-16"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2019-13056","kev_date_added":null,"published":"2019-07-02"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2024-56112","kev_date_added":null,"published":"2024-12-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"active","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-04","vendors":["n/a"]},"summary":"Remote attackers can bypass authentication and execute arbitrary commands in CyberPanel by exploiting a middleware flaw and shell metacharacters.","url":"https://insights.sbomify.com/CVE-2024-51567/"}