# CVE-2024-51567: CyberPanel Incorrect Default Permissions

> Remote attackers can bypass authentication and execute arbitrary commands in CyberPanel by exploiting a middleware flaw and shell metacharacters.

- **Severity:** Critical 10.0 (`CVSS:3.1/AC:L/AV:N/A:H/C:H/I:H/PR:N/S:C/UI:N`)
- **Exploited in the wild:** Yes, since 7 Nov 2024 (CISA KEV), used in ransomware
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Oct 2024
- **Updated:** 4 Aug 2026
- **Also known as:** GHSA-w6g2-qqv5-83qj

## What is CVE-2024-51567?

CVE-2024-51567 is a critical authentication bypass vulnerability in n/a, published on 29 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2024-51567?

It affects 1 product.


Products: Cyberpanel Cyberpanel.

## How do I fix CVE-2024-51567?

No fix has been published for CVE-2024-51567 yet. Limit exposure of the affected software until one is available. US federal agencies must fix it by 28 Nov 2024.

## Is CVE-2024-51567 being exploited?

Yes. Attackers have exploited CVE-2024-51567 in the wild since at least 7 Nov 2024, including in ransomware campaigns.

Public exploit code:

- CVE-2024-51567 is a Python PoC exploit targeting an RCE vulnerability in CyberPanel v2.3.6’s upgrademysqlstatus endpoint, bypassing CSRF protections. (github_poc): https://github.com/ajayalf/CVE-2024-51567
- cbyerpanel rce exploit (github_poc): https://github.com/thehash007/CVE-2024-51567-RCE-EXPLOIT
- CyberPanel Multi CVE Pre-auth RCE (metasploit)
- CVE-2024-51567 is a Python PoC exploit targeting an RCE vulnerability in CyberPanel v2.3.6’s upgrademysqlstatus endpoint, bypassing CSRF protections. (github_poc): https://github.com/KKDT12138/cve-2024-51567-poc
- CyberPanel v2.3.6 Pre-Auth Remote Code Execution (nuclei): http/cves/2024/CVE-2024-51567.yaml

## Other vulnerabilities in n/a

- [CVE-2024-51378](https://insights.sbomify.com/CVE-2024-51378/): CyberPanel Incorrect Default Permissions (critical 10.0, exploited in the wild)
- [CVE-2024-51568](https://insights.sbomify.com/CVE-2024-51568/): Command injection in n/a (critical 10.0)
- [CVE-2026-41473](https://insights.sbomify.com/CVE-2026-41473/): CyberPanel < 2.4.5 Unauthenticated API Access via AI Scanner Endpoints (high 8.8)
- [CVE-2024-53376](https://insights.sbomify.com/CVE-2024-53376/): Command injection in n/a (high 8.8)
- [CVE-2019-13056](https://insights.sbomify.com/CVE-2019-13056/): Cross-site request forgery in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-51567 and fix it if it is affected.

What it is: CVE-2024-51567 is a critical authentication bypass vulnerability in n/a, published on 29 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2024-51567 in the wild since at least 7 Nov 2024, including in ransomware campaigns.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-51567/ (Markdown: https://insights.sbomify.com/CVE-2024-51567/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-51567
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-51567
- OSV: https://osv.dev/vulnerability/CVE-2024-51567

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-51567/
Summaries are generated and may contain mistakes; the official description above is the record.
