CVE-2024-51569 Memory corruption in Apache NimBLE

High 7.5 Published Updated

A missing input validation in Apache NimBLE allows out-of-bounds reads when parsing HCI events, potentially causing crashes or information leaks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-51569?

CVE-2024-51569 is a high-severity memory corruption vulnerability in Apache NimBLE, published on 26 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Out-of-bounds Read vulnerability in Apache NimBLE.

Missing proper validation of HCI Number Of Completed Packets could lead to out-of-bound access when parsing HCI event and invalid read from HCI transport memory. This issue requires broken or bogus Bluetooth controller and thus severity is considered low. This issue affects Apache NimBLE: through 1.7.0.

Users are recommended to upgrade to version 1.8.0, which fixes the issue.

Weakness: CWE-125

Which versions are affected by CVE-2024-51569?

It affects 1 product.

Products include Apache Nimble.

How do I fix CVE-2024-51569?

No fix has been published for CVE-2024-51569 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2024-51569 being exploited?

There is no known exploitation of CVE-2024-51569 in the wild and no public exploit code.

Sources

Also known as GHSA-966f-2c6j-qj89.

Is CVE-2024-51569 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free