{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51774 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2024-51774 is a high-severity vulnerability in n/a, published on 2 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-51774 and fix it if it is affected.\n\nWhat it is: CVE-2024-51774 is a high-severity vulnerability in n/a, published on 2 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51774 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-51774/ (Markdown: https://insights.sbomify.com/CVE-2024-51774/index.md)","id":"CVE-2024-51774","markdown":"https://insights.sbomify.com/CVE-2024-51774/index.md","name":"CVE-2024-51774","record":{"aliases":["DEBIAN-CVE-2024-51774","GHSA-hfxc-7rp9-xw9w","UBUNTU-CVE-2024-51774","openSUSE-SU-2024:0358-1","openSUSE-SU-2024:14459-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"BitTorrent client","requires_auth":"none","summary":"qBittorrent fails to enforce HTTPS certificate validation, allowing attackers to bypass security checks and potentially intercept traffic.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"qbittorrent","vendor":"qbittorrent"}],"cvss":{"score":8.1,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"qBittorrent before 5.0.1 proceeds with use of https URLs even after certificate validation errors.","ecosystems":["SUSE:Package Hub 15 SP6","openSUSE:Leap 15.6","openSUSE:Tumbleweed"],"exploits":{"exploitdb":1,"first_seen":"2025-04-11","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-04-11","kind":"exploitdb","ref":"52190","stars":null,"title":"qBittorrent 5.0.1 - MITM RCE"}],"tier":"weaponised"},"has_fix":true,"headline":"Security feature bypass in n/a","id":"CVE-2024-51774","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"Apache Zeppelin: Command Injection via CSWSH","id":"CVE-2024-51775"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP6","fixed":["5.0.1-bp156.3.6.1"],"introduced":["0"],"last_affected":[],"package":"qbittorrent","purl":"pkg:rpm/suse/qbittorrent\u0026distro=SUSE%20Package%20Hub%2015%20SP6","source":"openSUSE-SU-2024:0358-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["5.0.1-bp156.3.6.1"],"introduced":["0"],"last_affected":[],"package":"qbittorrent","purl":"pkg:rpm/opensuse/qbittorrent\u0026distro=openSUSE%20Leap%2015.6","source":"openSUSE-SU-2024:0358-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.0.1-2.1"],"introduced":["0"],"last_affected":[],"package":"qbittorrent","purl":"pkg:rpm/opensuse/qbittorrent\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14459-1"}],"prev":{"headline":"Cross-site scripting in HPE Aruba Networking ClearPass Policy Manager","id":"CVE-2024-51773"},"products":["n/a"],"published":"2024-11-02","related":[{"cvss_score":9.8,"headline":"qBittorrent Web UI Default Credentials Lead to RCE","id":"CVE-2023-30801","kev_date_added":null,"published":"2023-10-10"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2019-13640","kev_date_added":null,"published":"2019-07-17"},{"cvss_score":7.1,"headline":"Auth bypass in n/a","id":"CVE-2017-12778","kev_date_added":null,"published":"2019-05-09"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2017-6503","kev_date_added":null,"published":"2017-03-06"},{"cvss_score":6.1,"headline":"Other in n/a","id":"CVE-2017-6504","kev_date_added":null,"published":"2017-03-06"},{"cvss_score":4,"headline":"Path traversal in qBittorrent","id":"CVE-2025-54310","kev_date_added":null,"published":"2025-07-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-06","vendors":["n/a"]},"summary":"qBittorrent fails to enforce HTTPS certificate validation, allowing attackers to bypass security checks and potentially intercept traffic.","url":"https://insights.sbomify.com/CVE-2024-51774/"}