CVE-2024-51775 Apache Zeppelin: Command Injection via CSWSH

High 7.5 Published Updated

Attackers can access internal paragraph information via cross-site WebSocket hijacking due to missing origin validation in Apache Zeppelin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-51775?

CVE-2024-51775 is a high-severity vulnerability in Apache Zeppelin, published on 3 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Missing Origin Validation in WebSockets vulnerability in Apache Zeppelin.

The attacker could access the Zeppelin server from another origin without any restriction, and get internal information about paragraphs.  This issue affects Apache Zeppelin: from 0.11.1 before 0.12.0.

Users are recommended to upgrade to version 0.12.0, which fixes the issue.

Weakness: CWE-1385

Which versions are affected by CVE-2024-51775?

2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-shell. It affects 1 product.

PackageAffectedFixed in
org.apache.zeppelin:zeppelin-shell MavenFrom 0.11.10.12.0
org.apache.zeppelin:zeppelin-shell MavenFrom 0.11.10.12.0

Products include Apache Zeppelin.

How do I fix CVE-2024-51775?

Upgrade org.apache.zeppelin:zeppelin-shell to 0.12.0 or later.

Is CVE-2024-51775 being exploited?

There is no known exploitation of CVE-2024-51775 in the wild and no public exploit code.

Sources

Also known as GHSA-xg8j-j6vp-6h5w.

Is CVE-2024-51775 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free