# CVE-2024-51775: Apache Zeppelin: Command Injection via CSWSH

> Attackers can access internal paragraph information via cross-site WebSocket hijacking due to missing origin validation in Apache Zeppelin.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2025
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-xg8j-j6vp-6h5w

## What is CVE-2024-51775?

CVE-2024-51775 is a high-severity vulnerability in Apache Zeppelin, published on 3 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Missing Origin Validation in WebSockets vulnerability in Apache Zeppelin.

The attacker could access the Zeppelin server from another origin without any restriction, and get internal information about paragraphs. 
This issue affects Apache Zeppelin: from 0.11.1 before 0.12.0.

Users are recommended to upgrade to version 0.12.0, which fixes the issue.

Weakness: CWE-1385 (Missing Origin Validation in WebSockets)

## Which versions are affected by CVE-2024-51775?

2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-shell. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.zeppelin:zeppelin-shell` | Maven | From 0.11.1 | 0.12.0 |
| `org.apache.zeppelin:zeppelin-shell` | Maven | From 0.11.1 | 0.12.0 |

Products: Apache Zeppelin.

## How do I fix CVE-2024-51775?

Upgrade org.apache.zeppelin:zeppelin-shell to 0.12.0 or later.

## Is CVE-2024-51775 being exploited?

There is no known exploitation of CVE-2024-51775 in the wild and no public exploit code.

## Other vulnerabilities in Apache Zeppelin

- [CVE-2024-31864](https://insights.sbomify.com/CVE-2024-31864/): Apache Zeppelin: Remote code execution by adding malicious JDBC connection string (critical 9.8)
- [CVE-2024-31866](https://insights.sbomify.com/CVE-2024-31866/): Apache Zeppelin: Interpreter download command does not escape malicious code injection (critical 9.8)
- [CVE-2019-10095](https://insights.sbomify.com/CVE-2019-10095/): bash command injection in spark interpreter (critical 9.8)
- [CVE-2018-1317](https://insights.sbomify.com/CVE-2018-1317/): Improper Authentication in Apache Zeppelin (high 8.8)
- [CVE-2017-12619](https://insights.sbomify.com/CVE-2017-12619/): Session Fixation in Apache Zeppelin (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-51775 and fix it if it is affected.

What it is: CVE-2024-51775 is a high-severity vulnerability in Apache Zeppelin, published on 3 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-51775 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.zeppelin:zeppelin-shell (Maven): affected from 0.11.1; fixed in 0.12.0
- org.apache.zeppelin:zeppelin-shell (Maven): affected from 0.11.1; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-51775/ (Markdown: https://insights.sbomify.com/CVE-2024-51775/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-51775
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-51775
- OSV: https://osv.dev/vulnerability/CVE-2024-51775

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-51775/
Summaries are generated and may contain mistakes; the official description above is the record.
