{"answers":{"affected":"3 open source packages ship an affected version, including rabbit_common and rabbitmq.","exploited":"There is no known exploitation of CVE-2024-51988 in the wild and no public exploit code.","fix":"Upgrade rabbit_common to 3.12.11 or later.","what":"CVE-2024-51988 is a medium-severity missing authorization vulnerability in rabbitmq-server, published on 6 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-51988 and fix it if it is affected.\n\nWhat it is: CVE-2024-51988 is a medium-severity missing authorization vulnerability in rabbitmq-server, published on 6 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-51988 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rabbit_common (Hex): affected from 3.12.7; fixed in 3.12.11\n- rabbit_common (Hex): affected from 3.12.7; fixed in 3.12.11\n- rabbitmq (Bitnami): affected from 3.12.7; fixed in 3.12.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-51988/ (Markdown: https://insights.sbomify.com/CVE-2024-51988/index.md)","id":"CVE-2024-51988","markdown":"https://insights.sbomify.com/CVE-2024-51988/index.md","name":"CVE-2024-51988","record":{"aliases":["BIT-rabbitmq-2024-51988","GHSA-pj33-75x5-32j4"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"RabbitMQ message broker","requires_auth":"low_privilege","summary":"Authenticated users with HTTP API access can delete queues without proper configure permissions, leading to unauthorized data modification.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"RabbitMQ is a feature rich, multi-protocol messaging and streaming broker. In affected versions queue deletion via the HTTP API was not verifying the `configure` permission of the user. Users who had all of the following: 1. Valid credentials, 2. Some permissions for the target virtual host \u0026 3. HTTP API access. could delete queues it had no (deletion) permissions for. This issue has been addressed in version 3.12.11 of the open source rabbitMQ release and in versions 1.5.2, 3.13.0, and 4.0.0 of the tanzu release. Users are advised to upgrade. Users unable to upgrade may disable management plugin and use, for example, Prometheus and Grafana for monitoring.","ecosystems":["Bitnami","Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"HTTP API's queue deletion endpoint does not verify that the user has a required permission","id":"CVE-2024-51988","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Cross-site Scripting (XSS) Vulnerability in PasswordPusher","id":"CVE-2024-51989"},"packages":[{"ecosystem":"Bitnami","fixed":["3.12.11"],"introduced":["3.12.7"],"last_affected":[],"package":"rabbitmq","purl":"pkg:bitnami/rabbitmq","source":"BIT-rabbitmq-2024-51988"},{"ecosystem":"Hex","fixed":["3.12.11"],"introduced":["3.12.7"],"last_affected":[],"package":"rabbit_common","purl":null,"source":"GHSA-pj33-75x5-32j4"},{"ecosystem":"Hex","fixed":["3.12.11"],"introduced":["3.12.7"],"last_affected":[],"package":"rabbit_common","purl":"pkg:hex/rabbit_common","source":"GHSA-pj33-75x5-32j4"}],"prev":{"headline":"HTTP Client uses incorrect token after refresh in Duende.AccessTokenManagement.OpenIdConnect","id":"CVE-2024-51987"},"products":["rabbitmq-server"],"published":"2024-11-06","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-06","vendors":["rabbitmq"]},"summary":"Authenticated users with HTTP API access can delete queues without proper configure permissions, leading to unauthorized data modification.","url":"https://insights.sbomify.com/CVE-2024-51988/"}