# CVE-2024-51988: HTTP API's queue deletion endpoint does not verify that the user has a required permission

> Authenticated users with HTTP API access can delete queues without proper configure permissions, leading to unauthorized data modification.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2024
- **Updated:** 6 Nov 2024
- **Also known as:** BIT-rabbitmq-2024-51988, GHSA-pj33-75x5-32j4

## What is CVE-2024-51988?

CVE-2024-51988 is a medium-severity missing authorization vulnerability in rabbitmq-server, published on 6 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

RabbitMQ is a feature rich, multi-protocol messaging and streaming broker. In affected versions queue deletion via the HTTP API was not verifying the `configure` permission of the user. Users who had all of the following: 1. Valid credentials, 2. Some permissions for the target virtual host & 3. HTTP API access. could delete queues it had no (deletion) permissions for. This issue has been addressed in version 3.12.11 of the open source rabbitMQ release and in versions 1.5.2, 3.13.0, and 4.0.0 of the tanzu release. Users are advised to upgrade. Users unable to upgrade may disable management plugin and use, for example, Prometheus and Grafana for monitoring.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-51988?

3 open source packages ship an affected version, including rabbit_common and rabbitmq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbit_common` | Hex | From 3.12.7 | 3.12.11 |
| `rabbit_common` | Hex | From 3.12.7 | 3.12.11 |
| `rabbitmq` | Bitnami | From 3.12.7 | 3.12.11 |

## How do I fix CVE-2024-51988?

Upgrade rabbit_common to 3.12.11 or later.

## Is CVE-2024-51988 being exploited?

There is no known exploitation of CVE-2024-51988 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-51988 and fix it if it is affected.

What it is: CVE-2024-51988 is a medium-severity missing authorization vulnerability in rabbitmq-server, published on 6 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-51988 in the wild and no public exploit code.

Affected packages and fixed versions:
- rabbit_common (Hex): affected from 3.12.7; fixed in 3.12.11
- rabbit_common (Hex): affected from 3.12.7; fixed in 3.12.11
- rabbitmq (Bitnami): affected from 3.12.7; fixed in 3.12.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-51988/ (Markdown: https://insights.sbomify.com/CVE-2024-51988/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-51988
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-51988
- OSV: https://osv.dev/vulnerability/CVE-2024-51988

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-51988/
Summaries are generated and may contain mistakes; the official description above is the record.
