CVE-2024-51989 Cross-site Scripting (XSS) Vulnerability in PasswordPusher
Attackers can inject malicious JavaScript via account confirmation links in self-hosted Password Pusher instances with login enabled, leading to session hijacking or data exposure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2024-51989?
CVE-2024-51989 is a high-severity cross-site scripting vulnerability in pglombardo PasswordPusher, published on 7 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Password Pusher is an open source application to communicate sensitive information over the web. A cross-site scripting (XSS) vulnerability was identified in the PasswordPusher application, affecting versions `v1.41.1` through and including `v.1.48.0`. The issue arises from an un-sanitized parameter which could allow attackers to inject malicious JavaScript into the application. Users who self-host and have the login system enabled are affected. Exploitation of this vulnerability could expose user data, access to user sessions or take unintended actions on behalf of users. To exploit this vulnerability, an attacker would need to convince a user to click a malicious account confirmation link. It is highly recommended to update to version `v1.48.1` or later to mitigate this risk. There are no known workarounds for this vulnerability.
### Solution
Update to version `v1.48.1` or later where input sanitization has been applied to the account confirmation process. If updating is not immediately possible,
Weakness: CWE-79
Which versions are affected by CVE-2024-51989?
How do I fix CVE-2024-51989?
No fix has been published for CVE-2024-51989 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-51989 being exploited?
There is no known exploitation of CVE-2024-51989 in the wild and no public exploit code.
Sources
Also known as GHSA-5chg-cq29-gfqf.