{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-51989 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-51989 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-51989 is a high-severity cross-site scripting vulnerability in pglombardo PasswordPusher, published on 7 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-51989 and fix it if it is affected.\n\nWhat it is: CVE-2024-51989 is a high-severity cross-site scripting vulnerability in pglombardo PasswordPusher, published on 7 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-51989 in the wild and no public exploit code.\n\nAffected product: pglombardo PasswordPusher. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-51989/ (Markdown: https://insights.sbomify.com/CVE-2024-51989/index.md)","id":"CVE-2024-51989","markdown":"https://insights.sbomify.com/CVE-2024-51989/index.md","name":"CVE-2024-51989","record":{"aliases":["GHSA-5chg-cq29-gfqf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Password Pusher","requires_auth":"none","summary":"Attackers can inject malicious JavaScript via account confirmation links in self-hosted Password Pusher instances with login enabled, leading to session hijacking or data exposure.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Password Pusher is an open source application to communicate sensitive information over the web. A cross-site scripting (XSS) vulnerability was identified in the PasswordPusher application, affecting versions `v1.41.1` through and including `v.1.48.0`. The issue arises from an un-sanitized parameter which could allow attackers to inject malicious JavaScript into the application. Users who self-host and have the login system enabled are affected.  Exploitation of this vulnerability could expose user data, access to user sessions or take unintended actions on behalf of users. To exploit this vulnerability, an attacker would need to convince a user to click a malicious account confirmation link. It is highly recommended to update to version `v1.48.1` or later to mitigate this risk. There are no known workarounds for this vulnerability.\n\n### Solution\n\nUpdate to version `v1.48.1` or later where input sanitization has been applied to the account confirmation process.  If updating is not immediately possible,","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Cross-site Scripting (XSS) Vulnerability in PasswordPusher","id":"CVE-2024-51989","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2024"},"n_packages":0,"n_references":1,"next":{"headline":"Path traversal via crafted Git repositories in jj","id":"CVE-2024-51990"},"packages":[],"prev":{"headline":"HTTP API's queue deletion endpoint does not verify that the user has a required permission","id":"CVE-2024-51988"},"products":["PasswordPusher"],"published":"2024-11-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-07","vendors":["pglombardo"]},"summary":"Attackers can inject malicious JavaScript via account confirmation links in self-hosted Password Pusher instances with login enabled, leading to session hijacking or data exposure.","url":"https://insights.sbomify.com/CVE-2024-51989/"}