# CVE-2024-51989: Cross-site Scripting (XSS) Vulnerability in PasswordPusher

> Attackers can inject malicious JavaScript via account confirmation links in self-hosted Password Pusher instances with login enabled, leading to session hijacking or data exposure.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 7 Nov 2024
- **Updated:** 7 Nov 2024
- **Also known as:** GHSA-5chg-cq29-gfqf

## What is CVE-2024-51989?

CVE-2024-51989 is a high-severity cross-site scripting vulnerability in pglombardo PasswordPusher, published on 7 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Password Pusher is an open source application to communicate sensitive information over the web. A cross-site scripting (XSS) vulnerability was identified in the PasswordPusher application, affecting versions `v1.41.1` through and including `v.1.48.0`. The issue arises from an un-sanitized parameter which could allow attackers to inject malicious JavaScript into the application. Users who self-host and have the login system enabled are affected.  Exploitation of this vulnerability could expose user data, access to user sessions or take unintended actions on behalf of users. To exploit this vulnerability, an attacker would need to convince a user to click a malicious account confirmation link. It is highly recommended to update to version `v1.48.1` or later to mitigate this risk. There are no known workarounds for this vulnerability.

### Solution

Update to version `v1.48.1` or later where input sanitization has been applied to the account confirmation process.  If updating is not immediately possible,

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-51989?


## How do I fix CVE-2024-51989?

No fix has been published for CVE-2024-51989 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-51989 being exploited?

There is no known exploitation of CVE-2024-51989 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-51989 and fix it if it is affected.

What it is: CVE-2024-51989 is a high-severity cross-site scripting vulnerability in pglombardo PasswordPusher, published on 7 Nov 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-51989 in the wild and no public exploit code.

Affected product: pglombardo PasswordPusher. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-51989/ (Markdown: https://insights.sbomify.com/CVE-2024-51989/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-51989
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-51989
- OSV: https://osv.dev/vulnerability/CVE-2024-51989

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-51989/
Summaries are generated and may contain mistakes; the official description above is the record.
