{"answers":{"affected":"2 open source packages ship an affected version, including jj-lib.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51990 exists.","fix":"Upgrade jj-lib to 0.23.0 or later.","what":"CVE-2024-51990 is a critical path traversal vulnerability in martinvonz jj, published on 7 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-51990 and fix it if it is affected.\n\nWhat it is: CVE-2024-51990 is a critical path traversal vulnerability in martinvonz jj, published on 7 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-51990 exists.\n\nAffected packages and fixed versions:\n- jj-lib (crates.io): affected all versions; fixed in 0.23.0\n- jj-lib (crates.io): affected all versions; fixed in 0.23.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-51990/ (Markdown: https://insights.sbomify.com/CVE-2024-51990/index.md)","id":"CVE-2024-51990","markdown":"https://insights.sbomify.com/CVE-2024-51990/index.md","name":"CVE-2024-51990","record":{"aliases":["GHSA-88h5-6w7m-5w56","openSUSE-SU-2024:14485-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Git-compatible VCS","requires_auth":"none","summary":"Attackers can craft Git repositories to force jj to write files outside the intended directory, potentially modifying system files.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"jj, or Jujutsu, is a Git-compatible VCS written in rust. In affected versions specially crafted Git repositories can cause `jj` to write files outside the clone. This issue has been addressed in version 0.23.0. Users are advised to upgrade. Users unable to upgrade should avoid cloning repos from unknown sources.","ecosystems":["crates.io","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Path traversal via crafted Git repositories in jj","id":"CVE-2024-51990","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"October CMS Allows Unprotected SVG Rename in Media Manager","id":"CVE-2024-51991"},"packages":[{"ecosystem":"crates.io","fixed":["0.23.0"],"introduced":["0"],"last_affected":[],"package":"jj-lib","purl":null,"source":"GHSA-88h5-6w7m-5w56"},{"ecosystem":"crates.io","fixed":["0.23.0"],"introduced":["0"],"last_affected":[],"package":"jj-lib","purl":"pkg:cargo/jj-lib","source":"GHSA-88h5-6w7m-5w56"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.23.0-1.1"],"introduced":["0"],"last_affected":[],"package":"jujutsu","purl":"pkg:rpm/opensuse/jujutsu\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14485-1"}],"prev":{"headline":"Cross-site Scripting (XSS) Vulnerability in PasswordPusher","id":"CVE-2024-51989"},"products":["jj"],"published":"2024-11-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-07","vendors":["martinvonz"]},"summary":"Attackers can craft Git repositories to force jj to write files outside the intended directory, potentially modifying system files.","url":"https://insights.sbomify.com/CVE-2024-51990/"}