# CVE-2024-52004: Remote code execution vulnerabilities in MediaCMS

> Attackers can achieve remote code execution by uploading malicious media files if user uploads are enabled.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Nov 2024
- **Updated:** 12 Nov 2024
- **Also known as:** GHSA-x3p4-4442-q2c3

## What is CVE-2024-52004?

CVE-2024-52004 is a high-severity vulnerability in mediacms-io mediacms, published on 8 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MediaCMS is an open source video and media CMS, written in Python/Django and React, featuring a REST API. MediaCMS has been prone to vulnerabilities that upon special cases can lead to remote code execution. All versions before v4.1.0 are susceptible, and users are highly recommended to upgrade. The vulnerabilities are related with insufficient input validation while uploading media content. The condition to exploit the vulnerability is that the portal allows users to upload content. This issue has been patched in version 4.1.0. There are no known workarounds for this vulnerability.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-52004?


## How do I fix CVE-2024-52004?

No fix has been published for CVE-2024-52004 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-52004 being exploited?

There is no known exploitation of CVE-2024-52004 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52004 and fix it if it is affected.

What it is: CVE-2024-52004 is a high-severity vulnerability in mediacms-io mediacms, published on 8 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52004 in the wild and no public exploit code.

Affected product: mediacms-io mediacms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52004/ (Markdown: https://insights.sbomify.com/CVE-2024-52004/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52004
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52004
- OSV: https://osv.dev/vulnerability/CVE-2024-52004

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52004/
Summaries are generated and may contain mistakes; the official description above is the record.
