# CVE-2024-52007: XXE vulnerability in XSLT parsing in `org.hl7.fhir.core`

> An attacker can read sensitive host system files by submitting malicious XML with external entities to applications using the HAPI FHIR library.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Nov 2024
- **Updated:** 12 Nov 2024
- **Also known as:** GHSA-gr3c-q7xf-47vh, ROOT-APP-MAVEN-CVE-2024-52007

## What is CVE-2024-52007?

CVE-2024-52007 is a high-severity vulnerability in hapifhir org.hl7.fhir.core, published on 8 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. XSLT parsing performed by various components are vulnerable to XML external entity injections. A processed XML file with a malicious DTD tag ( <!DOCTYPE foo [<!ENTITY example SYSTEM "/etc/passwd"> ]> could produce XML containing data from the host system. This impacts use cases where org.hl7.fhir.core is being used to within a host where external clients can submit XML. This is related to GHSA-6cr6-ph3p-f5rf, in which its fix (#1571 & #1717) was incomplete. This issue has been addressed in release version 6.4.0 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2024-52007?

12 open source packages ship an affected version, including ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may, ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 and ca.uhn.hapi.fhir:org.hl7.fhir.r4.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may` | Maven | All versions | 6.4.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may` | Maven | All versions | 6.4.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu3` | Maven | All versions | 6.4.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.dstu3` | Maven | All versions | 6.4.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4` | Maven | All versions | 6.4.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4` | Maven | All versions | 6.4.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4b` | Maven | All versions | 6.4.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r4b` | Maven | All versions | 6.4.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r5` | Maven | All versions | 6.4.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.r5` | Maven | All versions | 6.4.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.utilities` | Maven | All versions | 6.4.0 |
| `ca.uhn.hapi.fhir:org.hl7.fhir.utilities` | Maven | All versions | 6.4.0 |

## How do I fix CVE-2024-52007?

Upgrade ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may to 6.4.0 or later.

## Is CVE-2024-52007 being exploited?

There is no known exploitation of CVE-2024-52007 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52007 and fix it if it is affected.

What it is: CVE-2024-52007 is a high-severity vulnerability in hapifhir org.hl7.fhir.core, published on 8 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52007 in the wild and no public exploit code.

Affected packages and fixed versions:
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may (Maven): affected all versions; fixed in 6.4.0
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may (Maven): affected all versions; fixed in 6.4.0
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 (Maven): affected all versions; fixed in 6.4.0
- ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 (Maven): affected all versions; fixed in 6.4.0
- ca.uhn.hapi.fhir:org.hl7.fhir.r4 (Maven): affected all versions; fixed in 6.4.0
- ca.uhn.hapi.fhir:org.hl7.fhir.r4 (Maven): affected all versions; fixed in 6.4.0
- ca.uhn.hapi.fhir:org.hl7.fhir.r4b (Maven): affected all versions; fixed in 6.4.0
- ca.uhn.hapi.fhir:org.hl7.fhir.r4b (Maven): affected all versions; fixed in 6.4.0
- ca.uhn.hapi.fhir:org.hl7.fhir.r5 (Maven): affected all versions; fixed in 6.4.0
- ca.uhn.hapi.fhir:org.hl7.fhir.r5 (Maven): affected all versions; fixed in 6.4.0
- ca.uhn.hapi.fhir:org.hl7.fhir.utilities (Maven): affected all versions; fixed in 6.4.0
- ca.uhn.hapi.fhir:org.hl7.fhir.utilities (Maven): affected all versions; fixed in 6.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52007/ (Markdown: https://insights.sbomify.com/CVE-2024-52007/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52007
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52007
- OSV: https://osv.dev/vulnerability/CVE-2024-52007

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52007/
Summaries are generated and may contain mistakes; the official description above is the record.
