{"answers":{"affected":"3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-52008 in the wild and no public exploit code.","fix":"Upgrade ethyca-fides to 2.50.0 or later.","what":"CVE-2024-52008 is a low-severity vulnerability in ethyca fides, published on 26 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-52008 and fix it if it is affected.\n\nWhat it is: CVE-2024-52008 is a low-severity vulnerability in ethyca fides, published on 26 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-52008 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ethyca-fides (PyPI): affected all versions; fixed in 2.50.0\n- ethyca-fides (PyPI): affected all versions; fixed in 2.50.0\n- ethyca-fides (PyPI): affected all versions; fixed in 2.50.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-52008/ (Markdown: https://insights.sbomify.com/CVE-2024-52008/index.md)","id":"CVE-2024-52008","markdown":"https://insights.sbomify.com/CVE-2024-52008/index.md","name":"CVE-2024-52008","record":{"aliases":["GHSA-v7vm-rhmg-8j2r","PYSEC-2026-1349"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Privacy engineering platform","requires_auth":"low_privilege","summary":"Attackers can bypass client-side password checks via API to set weak passwords, facilitating account takeover in Fides.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fides","vendor":"ethyca"}],"cvss":{"score":2,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-602","name":"Client-Side Enforcement of Server-Side Security"}],"description":"Fides is an open-source privacy engineering platform. The user invite acceptance API endpoint lacks server-side password policy enforcement, allowing users to set arbitrarily weak passwords by bypassing client-side validation. While the UI enforces password complexity requirements, direct API calls can circumvent these checks, enabling the creation of accounts with passwords as short as a single character. When an email messaging provider is enabled and a new user account is created in the system, an invite email containing a special link is sent to the new user's email address. This link directs the new user to a page where they can set their initial password. While the user interface implements password complexity checks, these validations are only performed client-side. The underlying `/api/v1/user/accept-invite` API endpoint does not implement the same password policy validations. This vulnerability allows an invited user to set an extremely weak password for their own account during the initial account setup process. Therefore that specific user's account can be compromised easily by an attacker guessing or brute forcing the password. The vulnerability has been patched in Fides version `2.50.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There are no known workarounds for this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Password Policy Bypass Vulnerability in Fides Webserver","id":"CVE-2024-52008","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Git credentials are exposed in atlantis logs","id":"CVE-2024-52009"},"packages":[{"ecosystem":"PyPI","fixed":["2.50.0"],"introduced":["0"],"last_affected":[],"package":"ethyca-fides","purl":null,"source":"GHSA-v7vm-rhmg-8j2r"},{"ecosystem":"PyPI","fixed":["2.50.0"],"introduced":["0"],"last_affected":[],"package":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","source":"GHSA-v7vm-rhmg-8j2r"},{"ecosystem":"PyPI","fixed":["2.50.0"],"introduced":["0"],"last_affected":[],"package":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","source":"PYSEC-2026-1349"}],"prev":{"headline":"XXE vulnerability in XSLT parsing in `org.hl7.fhir.core`","id":"CVE-2024-52007"},"products":["fides"],"published":"2024-11-26","related":[{"cvss_score":9.1,"headline":"Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine","id":"CVE-2024-45053","kev_date_added":null,"published":"2024-09-04"},{"cvss_score":8.8,"headline":"Remote Code Execution in Custom Integration Upload in Fides","id":"CVE-2023-41319","kev_date_added":null,"published":"2023-09-06"},{"cvss_score":8.6,"headline":"Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation","id":"CVE-2025-57817","kev_date_added":null,"published":"2025-09-08"},{"cvss_score":8.2,"headline":"Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides","id":"CVE-2023-48224","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.2,"headline":"Server-Side Request Forgery Vulnerability in Custom Integration Upload","id":"CVE-2023-46124","kev_date_added":null,"published":"2023-10-24"},{"cvss_score":7.5,"headline":"Fides vulnerable to Path Traversal in Webserver API","id":"CVE-2023-36827","kev_date_added":null,"published":"2023-07-05"},{"cvss_score":6.5,"headline":"Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints in Fides","id":"CVE-2024-35189","kev_date_added":null,"published":"2024-05-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-26","vendors":["ethyca"]},"summary":"Attackers can bypass client-side password checks via API to set weak passwords, facilitating account takeover in Fides.","url":"https://insights.sbomify.com/CVE-2024-52008/"}