# CVE-2024-52008: Password Policy Bypass Vulnerability in Fides Webserver

> Attackers can bypass client-side password checks via API to set weak passwords, facilitating account takeover in Fides.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Nov 2024
- **Updated:** 26 Nov 2024
- **Also known as:** GHSA-v7vm-rhmg-8j2r, PYSEC-2026-1349

## What is CVE-2024-52008?

CVE-2024-52008 is a low-severity vulnerability in ethyca fides, published on 26 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Fides is an open-source privacy engineering platform. The user invite acceptance API endpoint lacks server-side password policy enforcement, allowing users to set arbitrarily weak passwords by bypassing client-side validation. While the UI enforces password complexity requirements, direct API calls can circumvent these checks, enabling the creation of accounts with passwords as short as a single character. When an email messaging provider is enabled and a new user account is created in the system, an invite email containing a special link is sent to the new user's email address. This link directs the new user to a page where they can set their initial password. While the user interface implements password complexity checks, these validations are only performed client-side. The underlying `/api/v1/user/accept-invite` API endpoint does not implement the same password policy validations. This vulnerability allows an invited user to set an extremely weak password for their own account during the initial account setup process. Therefore that specific user's account can be compromised easily by an attacker guessing or brute forcing the password. The vulnerability has been patched in Fides version `2.50.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There are no known workarounds for this vulnerability.

Weakness: CWE-602 (Client-Side Enforcement of Server-Side Security)

## Which versions are affected by CVE-2024-52008?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | All versions | 2.50.0 |
| `ethyca-fides` | PyPI | All versions | 2.50.0 |
| `ethyca-fides` | PyPI | All versions | 2.50.0 |

Products: Ethyca Fides.

## How do I fix CVE-2024-52008?

Upgrade ethyca-fides to 2.50.0 or later.

## Is CVE-2024-52008 being exploited?

There is no known exploitation of CVE-2024-52008 in the wild and no public exploit code.

## Other vulnerabilities in ethyca fides

- [CVE-2024-45053](https://insights.sbomify.com/CVE-2024-45053/): Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine (critical 9.1)
- [CVE-2023-41319](https://insights.sbomify.com/CVE-2023-41319/): Remote Code Execution in Custom Integration Upload in Fides (high 8.8)
- [CVE-2025-57817](https://insights.sbomify.com/CVE-2025-57817/): Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation (high 8.6)
- [CVE-2023-48224](https://insights.sbomify.com/CVE-2023-48224/): Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides (high 8.2)
- [CVE-2023-46124](https://insights.sbomify.com/CVE-2023-46124/): Server-Side Request Forgery Vulnerability in Custom Integration Upload (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52008 and fix it if it is affected.

What it is: CVE-2024-52008 is a low-severity vulnerability in ethyca fides, published on 26 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-52008 in the wild and no public exploit code.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected all versions; fixed in 2.50.0
- ethyca-fides (PyPI): affected all versions; fixed in 2.50.0
- ethyca-fides (PyPI): affected all versions; fixed in 2.50.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52008/ (Markdown: https://insights.sbomify.com/CVE-2024-52008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52008
- OSV: https://osv.dev/vulnerability/CVE-2024-52008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52008/
Summaries are generated and may contain mistakes; the official description above is the record.
