# CVE-2024-52011: launch-editor vulnerable to command injection via the crafted request on Windows


- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLEANSTART-2026-BL91899, CLEANSTART-2026-XZ43182, CLSA-2026-1789376303, CLSA-2026-1792225955, GHSA-c27g-q93r-2cwf, MINI-h95m-c6j6-7m2w, ROOT-APP-NPM-CVE-2024-52011

## What is CVE-2024-52011?

CVE-2024-52011 is a high-severity vulnerability in vitejs launch-editor, published on 1 Jun 2026. 

### Official description

launch-editor allows users to open files with line numbers in editor from Node.js. Prior to version 2.9.0, due to the insufficient sanitization of the `file` argument in the `launchEditor`, an attacker can execute arbitrary commands on Windows by supplying a filename that contains special characters. This issue has been fixed in the `launch-editor` version 2.9.0, corresponding to vite version 5.4.9.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-52011?

4 open source packages ship an affected version, including launch-editor and vite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `launch-editor` | npm | All versions | 2.9.0 |
| `launch-editor` | npm | All versions | 2.9.0 |
| `vite` | npm | All versions | 5.4.9 |
| `vite` | npm | All versions | 5.4.9 |

## How do I fix CVE-2024-52011?

Upgrade launch-editor to 2.9.0 or later.

## Is CVE-2024-52011 being exploited?

There is no known exploitation of CVE-2024-52011 in the wild and no public exploit code.

Public exploit code:

- CVE-2024-52011 - Draft (github_poc): https://github.com/HORKimhab/CVE-2024-52011

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52011 and fix it if it is affected.

What it is: CVE-2024-52011 is a high-severity vulnerability in vitejs launch-editor, published on 1 Jun 2026. 
Exploitation: There is no known exploitation of CVE-2024-52011 in the wild and no public exploit code.

Affected packages and fixed versions:
- launch-editor (npm): affected all versions; fixed in 2.9.0
- launch-editor (npm): affected all versions; fixed in 2.9.0
- vite (npm): affected all versions; fixed in 5.4.9
- vite (npm): affected all versions; fixed in 5.4.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52011/ (Markdown: https://insights.sbomify.com/CVE-2024-52011/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52011
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52011
- OSV: https://osv.dev/vulnerability/CVE-2024-52011

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52011/
Summaries are generated and may contain mistakes; the official description above is the record.
