CVE-2024-52012 Apache Solr: Configset upload on Windows allows arbitrary path write-access
Attackers can write arbitrary files to the filesystem on Windows via malicious ZIP uploads in the configset API, requiring an upgrade to fix.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-52012?
CVE-2024-52012 is a medium-severity path traversal vulnerability in Apache Solr, published on 27 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Relative Path Traversal vulnerability in Apache Solr.
Solr instances running on Windows are vulnerable to arbitrary filepath write-access, due to a lack of input-sanitation in the "configset upload" API. Commonly known as a "zipslip", maliciously constructed ZIP files can use relative filepaths to write data to unanticipated parts of the filesystem. This issue affects Apache Solr: from 6.6 through 9.7.0.
Users are recommended to upgrade to version 9.8.0, which fixes the issue. Users unable to upgrade may also safely prevent the issue by using Solr's "Rule-Based Authentication Plugin" to restrict access to the configset upload API, so that it can only be accessed by a trusted set of administrators/users.
Weakness: CWE-23
Which versions are affected by CVE-2024-52012?
3 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.solr:solr-core Maven | From 6.6 | 9.8.0 |
org.apache.solr:solr-core Maven | From 6.6 | 9.8.0 |
solr Bitnami | From 6.6.0 | 9.8.0 |
Products include Apache Solr.
How do I fix CVE-2024-52012?
Upgrade org.apache.solr:solr-core to 9.8.0 or later.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2024-52012 being exploited?
There is no known exploitation of CVE-2024-52012 in the wild and no public exploit code.
Other vulnerabilities in Apache Solr
- CVE-2019-17558 Apache Solr VelocityResponseWriter Plug-In Remote Code Execution
- CVE-2019-0193 Apache Solr DataImportHandler Code Injection
- CVE-2024-45216 Apache Solr: Authentication bypass possible using a fake URL Path ending
- CVE-2021-44548 Apache Solr information disclosure vulnerability through DataImportHandler
- CVE-2021-27905 SSRF vulnerability with the Replication handler
Sources
Also known as BIT-solr-2024-52012, GHSA-4p5m-gvpf-f3x5.