# CVE-2024-52012: Apache Solr: Configset upload on Windows allows arbitrary path write-access

> Attackers can write arbitrary files to the filesystem on Windows via malicious ZIP uploads in the configset API, requiring an upgrade to fix.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2025
- **Updated:** 6 Feb 2025
- **Also known as:** BIT-solr-2024-52012, GHSA-4p5m-gvpf-f3x5

## What is CVE-2024-52012?

CVE-2024-52012 is a medium-severity path traversal vulnerability in Apache Solr, published on 27 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Relative Path Traversal vulnerability in Apache Solr.

Solr instances running on Windows are vulnerable to arbitrary filepath write-access, due to a lack of input-sanitation in the "configset upload" API.  Commonly known as a "zipslip", maliciously constructed ZIP files can use relative filepaths to write data to unanticipated parts of the filesystem.  
This issue affects Apache Solr: from 6.6 through 9.7.0.

Users are recommended to upgrade to version 9.8.0, which fixes the issue.  Users unable to upgrade may also safely prevent the issue by using Solr's "Rule-Based Authentication Plugin" to restrict access to the configset upload API, so that it can only be accessed by a trusted set of administrators/users.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2024-52012?

3 open source packages ship an affected version, including org.apache.solr:solr-core and solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | From 6.6 | 9.8.0 |
| `org.apache.solr:solr-core` | Maven | From 6.6 | 9.8.0 |
| `solr` | Bitnami | From 6.6.0 | 9.8.0 |

Products: Apache Solr.

## How do I fix CVE-2024-52012?

Upgrade org.apache.solr:solr-core to 9.8.0 or later.

## Is CVE-2024-52012 being exploited?

There is no known exploitation of CVE-2024-52012 in the wild and no public exploit code.

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52012 and fix it if it is affected.

What it is: CVE-2024-52012 is a medium-severity path traversal vulnerability in Apache Solr, published on 27 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52012 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected from 6.6; fixed in 9.8.0
- org.apache.solr:solr-core (Maven): affected from 6.6; fixed in 9.8.0
- solr (Bitnami): affected from 6.6.0; fixed in 9.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52012/ (Markdown: https://insights.sbomify.com/CVE-2024-52012/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52012
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52012
- OSV: https://osv.dev/vulnerability/CVE-2024-52012

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52012/
Summaries are generated and may contain mistakes; the official description above is the record.
