# CVE-2024-52067: Apache NiFi: Potential Insertion of Sensitive Parameter Values in Debug Log

> An authorized administrator can enable debug logging to expose sensitive Parameter Context values in application logs, requiring an upgrade to mitigate.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N/AU:Y/R:U/V:D/RE:L/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2024
- **Updated:** 21 Nov 2024
- **Also known as:** GHSA-v3vc-6qcv-4vrx

## What is CVE-2024-52067?

CVE-2024-52067 is a medium-severity vulnerability in Apache Nifi, published on 21 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Apache NiFi 1.16.0 through 1.28.0 and 2.0.0-M1 through 2.0.0-M4 include optional debug logging of Parameter Context values during the flow synchronization process. An authorized administrator with access to change logging levels could enable debug logging for framework flow synchronization, causing the application to write Parameter names and values to the application log. Parameter Context values may contain sensitive information depending on application flow configuration. Deployments of Apache NiFi with the default Logback configuration do not log Parameter Context values. Upgrading to Apache NiFi 2.0.0 or 1.28.1 is the recommendation mitigation, eliminating Parameter value logging from the flow synchronization process regardless of the Logback configuration.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2024-52067?

4 open source packages ship an affected version, including org.apache.nifi:nifi-framework-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-framework-core` | Maven | From 1.16.0 | 1.28.1 |
| `org.apache.nifi:nifi-framework-core` | Maven | From 1.16.0 | 1.28.1 |
| `org.apache.nifi:nifi-framework-core` | Maven | From 2.0.0-M1 | 2.0.0 |
| `org.apache.nifi:nifi-framework-core` | Maven | From 2.0.0-M1 | 2.0.0 |

Products: Apache Nifi.

## How do I fix CVE-2024-52067?

Upgrade org.apache.nifi:nifi-framework-core to a fixed version for your release line: 1.28.1 or 2.0.0.

## Is CVE-2024-52067 being exploited?

There is no known exploitation of CVE-2024-52067 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52067 and fix it if it is affected.

What it is: CVE-2024-52067 is a medium-severity vulnerability in Apache Nifi, published on 21 Nov 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52067 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-framework-core (Maven): affected from 1.16.0; fixed in 1.28.1
- org.apache.nifi:nifi-framework-core (Maven): affected from 1.16.0; fixed in 1.28.1
- org.apache.nifi:nifi-framework-core (Maven): affected from 2.0.0-M1; fixed in 2.0.0
- org.apache.nifi:nifi-framework-core (Maven): affected from 2.0.0-M1; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52067/ (Markdown: https://insights.sbomify.com/CVE-2024-52067/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52067
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52067
- OSV: https://osv.dev/vulnerability/CVE-2024-52067

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52067/
Summaries are generated and may contain mistakes; the official description above is the record.
