{"answers":{"affected":"3 open source packages ship an affected version, including litellm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5225 exists.","fix":"Upgrade litellm to 1.40.0 or later.","what":"CVE-2024-5225 is a medium-severity SQL injection vulnerability in berriai/litellm, published on 6 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-5225 and fix it if it is affected.\n\nWhat it is: CVE-2024-5225 is a medium-severity SQL injection vulnerability in berriai/litellm, published on 6 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5225 exists.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected all versions; fixed in 1.40.0\n- litellm (PyPI): affected all versions; fixed in 1.40.0\n- litellm (PyPI): affected all versions; fixed in 1.40.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-5225/ (Markdown: https://insights.sbomify.com/CVE-2024-5225/index.md)","id":"CVE-2024-5225","markdown":"https://insights.sbomify.com/CVE-2024-5225/index.md","name":"CVE-2024-5225","record":{"aliases":["GHSA-h6m6-jj8v-94jj","PYSEC-2026-1550"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"LiteLLM Python library","requires_auth":"low_privilege","summary":"Attackers can inject SQL via the api_key parameter in the spend logs endpoint to read or modify data in LiteLLM.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"litellm","vendor":"litellm"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"An SQL Injection vulnerability exists in the berriai/litellm repository, specifically within the `/global/spend/logs` endpoint. The vulnerability arises due to improper neutralization of special elements used in an SQL command. The affected code constructs an SQL query by concatenating an unvalidated `api_key` parameter directly into the query, making it susceptible to SQL Injection if the `api_key` contains malicious data. This issue affects the latest version of the repository. Successful exploitation of this vulnerability could lead to unauthorized access, data manipulation, exposure of confidential information, and denial of service (DoS).","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"SQL Injection in berriai/litellm","id":"CVE-2024-5225","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"sql_injection","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Fuse Social Floating Sidebar \u003c= 5.4.10 - Authenticated (Author+) Stored Cross-Site Scripting via File Upload","id":"CVE-2024-5226"},"packages":[{"ecosystem":"PyPI","fixed":["1.40.0"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":null,"source":"GHSA-h6m6-jj8v-94jj"},{"ecosystem":"PyPI","fixed":["1.40.0"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-h6m6-jj8v-94jj"},{"ecosystem":"PyPI","fixed":["1.40.0"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"PYSEC-2026-1550"}],"prev":{"headline":"Cross-site scripting in Easy Social Like Box – Popup – Sidebar Widget","id":"CVE-2024-5224"},"products":["berriai/litellm"],"published":"2024-06-06","related":[{"cvss_score":9.3,"headline":"BerriAI LiteLLM SQL Injection","id":"CVE-2026-42208","kev_date_added":"2026-05-08","published":"2026-05-08"},{"cvss_score":8.8,"headline":"BerriAI LiteLLM Improper Authentication","id":"CVE-2026-59822","kev_date_added":"2026-09-02","published":"2026-07-08"},{"cvss_score":8.7,"headline":"BerriAI LiteLLM Command Injection","id":"CVE-2026-42271","kev_date_added":"2026-06-08","published":"2026-05-08"},{"cvss_score":9.8,"headline":"Remote Code Execution in BerriAI/litellm","id":"CVE-2024-5751","kev_date_added":null,"published":"2024-06-27"},{"cvss_score":9.8,"headline":"Server-Side Template Injection in BerriAI/litellm","id":"CVE-2024-2952","kev_date_added":null,"published":"2024-04-10"},{"cvss_score":9.5,"headline":"LiteLLM: Authentication Bypass via Host Header Injection","id":"CVE-2026-49468","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.4,"headline":"LiteLLM has an authentication bypass via OIDC userinfo cache key collision","id":"CVE-2026-35030","kev_date_added":null,"published":"2026-04-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["berriai"]},"summary":"Attackers can inject SQL via the api_key parameter in the spend logs endpoint to read or modify data in LiteLLM.","url":"https://insights.sbomify.com/CVE-2024-5225/"}