# CVE-2024-5225: SQL Injection in berriai/litellm

> Attackers can inject SQL via the api_key parameter in the spend logs endpoint to read or modify data in LiteLLM.

- **Severity:** Medium 6.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-h6m6-jj8v-94jj, PYSEC-2026-1550

## What is CVE-2024-5225?

CVE-2024-5225 is a medium-severity SQL injection vulnerability in berriai/litellm, published on 6 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An SQL Injection vulnerability exists in the berriai/litellm repository, specifically within the `/global/spend/logs` endpoint. The vulnerability arises due to improper neutralization of special elements used in an SQL command. The affected code constructs an SQL query by concatenating an unvalidated `api_key` parameter directly into the query, making it susceptible to SQL Injection if the `api_key` contains malicious data. This issue affects the latest version of the repository. Successful exploitation of this vulnerability could lead to unauthorized access, data manipulation, exposure of confidential information, and denial of service (DoS).

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-5225?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.40.0 |
| `litellm` | PyPI | All versions | 1.40.0 |
| `litellm` | PyPI | All versions | 1.40.0 |

Products: Litellm Litellm.

## How do I fix CVE-2024-5225?

Upgrade litellm to 1.40.0 or later.

## Is CVE-2024-5225 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5225 exists.

## Other vulnerabilities in berriai/litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5225 and fix it if it is affected.

What it is: CVE-2024-5225 is a medium-severity SQL injection vulnerability in berriai/litellm, published on 6 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5225 exists.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.40.0
- litellm (PyPI): affected all versions; fixed in 1.40.0
- litellm (PyPI): affected all versions; fixed in 1.40.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5225/ (Markdown: https://insights.sbomify.com/CVE-2024-5225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5225
- OSV: https://osv.dev/vulnerability/CVE-2024-5225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5225/
Summaries are generated and may contain mistakes; the official description above is the record.
