CVE-2024-52279 Apache Zeppelin: Arbitrary file read by adding malicious JDBC connection string

High 7.5 Published Updated

Attackers can read arbitrary files by bypassing JDBC URL validation with encoded input in Apache Zeppelin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-52279?

CVE-2024-52279 is a high-severity path traversal vulnerability in Apache Zeppelin, published on 3 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Input Validation vulnerability in Apache Zeppelin. The fix for JDBC URL validation in CVE-2024-31864 did not account for URL encoded input.

This issue affects Apache Zeppelin: from 0.11.1 before 0.12.0.

Users are recommended to upgrade to version 0.12.0, which fixes the issue.

Weakness: CWE-20

Which versions are affected by CVE-2024-52279?

2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-jdbc. It affects 1 product.

PackageAffectedFixed in
org.apache.zeppelin:zeppelin-jdbc MavenFrom 0.11.10.12.0
org.apache.zeppelin:zeppelin-jdbc MavenFrom 0.11.10.12.0

Products include Apache Zeppelin.

How do I fix CVE-2024-52279?

Upgrade org.apache.zeppelin:zeppelin-jdbc to 0.12.0 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2024-52279 being exploited?

There is no known exploitation of CVE-2024-52279 in the wild and no public exploit code.

Sources

Also known as GHSA-jr43-q92q-5q82.

Is CVE-2024-52279 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free