{"answers":{"affected":"3 open source packages ship an affected version, including github.com/rancher/rancher.","exploited":"There is no known exploitation of CVE-2024-52281 in the wild and no public exploit code.","fix":"Upgrade github.com/rancher/rancher to 2.9.4 or later.","what":"CVE-2024-52281 is a high-severity cross-site scripting vulnerability in SUSE rancher, published on 16 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-52281 and fix it if it is affected.\n\nWhat it is: CVE-2024-52281 is a high-severity cross-site scripting vulnerability in SUSE rancher, published on 16 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-52281 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/rancher/rancher (Go): affected all versions; no fix listed\n- github.com/rancher/rancher (Go): affected from 2.9.0; fixed in 2.9.4\n- github.com/rancher/rancher (Go): affected from 2.9.0; fixed in 2.9.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-52281/ (Markdown: https://insights.sbomify.com/CVE-2024-52281/index.md)","id":"CVE-2024-52281","markdown":"https://insights.sbomify.com/CVE-2024-52281/index.md","name":"CVE-2024-52281","record":{"aliases":["GHSA-2v2w-8v8c-wcm9","GO-2025-3391"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Rancher UI","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via the cluster description field in Rancher UI, potentially compromising user sessions and data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[],"cvss":{"score":8.9,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A: Improper Neutralization of Input During Web Page Generation vulnerability in SUSE rancher allows a malicious actor to perform a Stored XSS attack through the cluster description field.\nThis issue affects rancher: from 2.9.0 before 2.9.4.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored Cross-site Scripting vulnerability in Rancher UI","id":"CVE-2024-52281","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Rancher Helm Applications may have sensitive values leaked","id":"CVE-2024-52282"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":"pkg:golang/github.com/rancher/rancher","source":"GO-2025-3391"},{"ecosystem":"Go","fixed":["2.9.4"],"introduced":["2.9.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":null,"source":"GHSA-2v2w-8v8c-wcm9"},{"ecosystem":"Go","fixed":["2.9.4"],"introduced":["2.9.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":"pkg:golang/github.com/rancher/rancher","source":"GHSA-2v2w-8v8c-wcm9"}],"prev":{"headline":"Users can issue watch commands for arbitrary resources","id":"CVE-2024-52280"},"products":["rancher"],"published":"2025-04-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["SUSE"]},"summary":"Attackers can inject malicious scripts via the cluster description field in Rancher UI, potentially compromising user sessions and data.","url":"https://insights.sbomify.com/CVE-2024-52281/"}