CVE-2024-52282 Rancher Helm Applications may have sensitive values leaked
Users with catalog access can read sensitive Helm application values, exposing secrets to unauthorized actors.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-52282?
CVE-2024-52282 is a medium-severity vulnerability in SUSE rancher, published on 11 Apr 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
A Exposure of Sensitive Information to an Unauthorized Actor vulnerability in SUSE rancher allowing any users with GET access to the Rancher Manager Apps Catalog to read any sensitive information that are contained within the Apps’ values. Additionally, the same information leaks into auditing logs when the audit level is set to equal or above 2.
This issue affects rancher: from 2.8.0 before 2.8.10, from 2.9.0 before 2.9.4.
Weakness: CWE-200
Which versions are affected by CVE-2024-52282?
5 open source packages ship an affected version, including github.com/rancher/rancher.
| Package | Affected | Fixed in |
|---|---|---|
github.com/rancher/rancher Go | All versions | None |
github.com/rancher/rancher Go | From 2.8.0 | 2.8.10 |
github.com/rancher/rancher Go | From 2.8.0 | 2.8.10 |
github.com/rancher/rancher Go | From 2.9.0 | 2.9.4 |
github.com/rancher/rancher Go | From 2.9.0 | 2.9.4 |
How do I fix CVE-2024-52282?
Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.8.10 or 2.9.4.
Is CVE-2024-52282 being exploited?
There is no known exploitation of CVE-2024-52282 in the wild and no public exploit code.
Sources
Also known as GHSA-9c5p-35gj-jqp4, GO-2024-3280.