{"answers":{"affected":"5 open source packages ship an affected version, including github.com/rancher/rancher.","exploited":"There is no known exploitation of CVE-2024-52282 in the wild and no public exploit code.","fix":"Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.8.10 or 2.9.4.","what":"CVE-2024-52282 is a medium-severity vulnerability in SUSE rancher, published on 11 Apr 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-52282 and fix it if it is affected.\n\nWhat it is: CVE-2024-52282 is a medium-severity vulnerability in SUSE rancher, published on 11 Apr 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-52282 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/rancher/rancher (Go): affected all versions; no fix listed\n- github.com/rancher/rancher (Go): affected from 2.8.0; fixed in 2.8.10\n- github.com/rancher/rancher (Go): affected from 2.8.0; fixed in 2.8.10\n- github.com/rancher/rancher (Go): affected from 2.9.0; fixed in 2.9.4\n- github.com/rancher/rancher (Go): affected from 2.9.0; fixed in 2.9.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-52282/ (Markdown: https://insights.sbomify.com/CVE-2024-52282/index.md)","id":"CVE-2024-52282","markdown":"https://insights.sbomify.com/CVE-2024-52282/index.md","name":"CVE-2024-52282","record":{"aliases":["GHSA-9c5p-35gj-jqp4","GO-2024-3280"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Rancher management platform","requires_auth":"high_privilege","summary":"Users with catalog access can read sensitive Helm application values, exposing secrets to unauthorized actors.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[],"cvss":{"score":6.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A Exposure of Sensitive Information to an Unauthorized Actor vulnerability in SUSE rancher allowing any users with GET\n access to the Rancher Manager Apps Catalog to read any sensitive information that are \ncontained within the Apps’ values. Additionally, the same information \nleaks into auditing logs when the audit level is set to equal or above \n2.\n\nThis issue affects rancher: from 2.8.0 before 2.8.10, from 2.9.0 before 2.9.4.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Rancher Helm Applications may have sensitive values leaked","id":"CVE-2024-52282","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":5,"n_references":2,"next":{"headline":"Cross-site scripting in hackweek","id":"CVE-2024-52283"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":"pkg:golang/github.com/rancher/rancher","source":"GO-2024-3280"},{"ecosystem":"Go","fixed":["2.8.10"],"introduced":["2.8.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":null,"source":"GHSA-9c5p-35gj-jqp4"},{"ecosystem":"Go","fixed":["2.8.10"],"introduced":["2.8.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":"pkg:golang/github.com/rancher/rancher","source":"GHSA-9c5p-35gj-jqp4"},{"ecosystem":"Go","fixed":["2.9.4"],"introduced":["2.9.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":null,"source":"GHSA-9c5p-35gj-jqp4"},{"ecosystem":"Go","fixed":["2.9.4"],"introduced":["2.9.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":"pkg:golang/github.com/rancher/rancher","source":"GHSA-9c5p-35gj-jqp4"}],"prev":{"headline":"Stored Cross-site Scripting vulnerability in Rancher UI","id":"CVE-2024-52281"},"products":["rancher"],"published":"2025-04-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-11","vendors":["SUSE"]},"summary":"Users with catalog access can read sensitive Helm application values, exposing secrets to unauthorized actors.","url":"https://insights.sbomify.com/CVE-2024-52282/"}