# CVE-2024-52290: Stored XSS in Configuration Key Functionality

> An attacker with modification rights can inject XSS payloads into configuration keys, allowing code execution in the browser of users who delete those keys.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2025
- **Updated:** 14 May 2025
- **Also known as:** GHSA-9cwv-pxcr-hfjc, GO-2025-3682

## What is CVE-2024-52290?

CVE-2024-52290 is a medium-severity cross-site scripting vulnerability in lf-edge ekuiper, published on 14 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

LF Edge eKuiper is a lightweight internet of things (IoT) data analytics and stream processing engine. Prior to version 2.1.0 user with rights to modificate the service (e.g. kuiperUser role) can inject a cross-site scripting payload into Connection Configuration key `Name` (`confKey`) parameter. After this setup, when any user with access to this service (e.g. admin) tries to delete this key, a payload acts in the victim's browser. Version 2.1.0 fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-52290?

6 open source packages ship an affected version, including github.com/lf-edge/ekuiper and github.com/lf-edge/ekuiper/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lf-edge/ekuiper` | Go | All versions | None |
| `github.com/lf-edge/ekuiper` | Go | All versions to 1.14.7 | None |
| `github.com/lf-edge/ekuiper` | Go | All versions to 1.14.7 | None |
| `github.com/lf-edge/ekuiper/v2` | Go | All versions | 2.1.0 |
| `github.com/lf-edge/ekuiper/v2` | Go | All versions | 2.1.0 |
| `github.com/lf-edge/ekuiper/v2` | Go | All versions | 2.1.0 |

Products: Lfedge Ekuiper.

## How do I fix CVE-2024-52290?

Upgrade to a fixed version.

## Is CVE-2024-52290 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52290 exists.

## Other vulnerabilities in lf-edge ekuiper

- [CVE-2025-54379](https://insights.sbomify.com/CVE-2025-54379/): eKuiper API endpoints handling SQL queries with user-controlled table names. (high 8.9)
- [CVE-2024-43406](https://insights.sbomify.com/CVE-2024-43406/): LF Edge eKuiper has a SQL Injection in sqlKvStore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52290 and fix it if it is affected.

What it is: CVE-2024-52290 is a medium-severity cross-site scripting vulnerability in lf-edge ekuiper, published on 14 May 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52290 exists.

Affected packages and fixed versions:
- github.com/lf-edge/ekuiper (Go): affected all versions; no fix listed
- github.com/lf-edge/ekuiper (Go): affected all versions up to 1.14.7; no fix listed
- github.com/lf-edge/ekuiper (Go): affected all versions up to 1.14.7; no fix listed
- github.com/lf-edge/ekuiper/v2 (Go): affected all versions; fixed in 2.1.0
- github.com/lf-edge/ekuiper/v2 (Go): affected all versions; fixed in 2.1.0
- github.com/lf-edge/ekuiper/v2 (Go): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52290/ (Markdown: https://insights.sbomify.com/CVE-2024-52290/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52290
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52290
- OSV: https://osv.dev/vulnerability/CVE-2024-52290

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52290/
Summaries are generated and may contain mistakes; the official description above is the record.
