CVE-2024-52293 Craft has a Potential Remote Code Execution via missing path normalization & Twig SSTI
Attackers can achieve remote code execution on Craft CMS servers via Twig SSTI due to missing path normalization in file handling.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-52293?
CVE-2024-52293 is a high-severity code injection vulnerability in Craftcms Craft Cms, published on 13 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Craft is a content management system (CMS). Prior to 4.12.2 and 5.4.3, Craft is missing normalizePath in the function FileHelper::absolutePath could lead to Remote Code Execution on the server via twig SSTI. This is a sequel to CVE-2023-40035. This vulnerability is fixed in 4.12.2 and 5.4.3.
Weakness: CWE-22
Which versions are affected by CVE-2024-52293?
4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.12.2 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.12.2 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.4.3 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.4.3 |
Products include Craftcms Craft Cms.
How do I fix CVE-2024-52293?
Upgrade craftcms/cms to a fixed version for your release line: 4.12.2 or 5.4.3.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2024-52293 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52293 exists.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-f3cw-hg6r-chfv.