# CVE-2024-52293: Craft has a Potential Remote Code Execution via missing path normalization & Twig SSTI

> Attackers can achieve remote code execution on Craft CMS servers via Twig SSTI due to missing path normalization in file handling.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Nov 2024
- **Updated:** 13 Nov 2024
- **Also known as:** GHSA-f3cw-hg6r-chfv

## What is CVE-2024-52293?

CVE-2024-52293 is a high-severity code injection vulnerability in Craftcms Craft Cms, published on 13 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Craft is a content management system (CMS). Prior to 4.12.2 and 5.4.3, Craft is missing normalizePath in the function FileHelper::absolutePath could lead to Remote Code Execution on the server via twig SSTI. This is a sequel to CVE-2023-40035. This vulnerability is fixed in 4.12.2 and 5.4.3.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-52293?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.12.2 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.12.2 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.4.3 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.4.3 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2024-52293?

Upgrade craftcms/cms to a fixed version for your release line: 4.12.2 or 5.4.3.

## Is CVE-2024-52293 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52293 exists.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52293 and fix it if it is affected.

What it is: CVE-2024-52293 is a high-severity code injection vulnerability in Craftcms Craft Cms, published on 13 Nov 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52293 exists.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.12.2
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.12.2
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.4.3
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52293/ (Markdown: https://insights.sbomify.com/CVE-2024-52293/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52293
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52293
- OSV: https://osv.dev/vulnerability/CVE-2024-52293

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52293/
Summaries are generated and may contain mistakes; the official description above is the record.
