# CVE-2024-52294: khoj has an IDOR in subscription management that allows unauthorized subscription modifications

> Authenticated users can modify other users' Stripe subscriptions by manipulating the email parameter due to missing ownership checks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Dec 2024
- **Updated:** 30 Dec 2024
- **Also known as:** GHSA-hq4h-w933-jm6c, PYSEC-2026-1493

## What is CVE-2024-52294?

CVE-2024-52294 is a medium-severity missing authorization vulnerability in khoj-ai khoj, published on 30 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Khoj is a self-hostable artificial intelligence app. Prior to version 1.29.10, an Insecure Direct Object Reference (IDOR) vulnerability in the update_subscription endpoint allows any authenticated user to manipulate other users' Stripe subscriptions by simply modifying the email parameter in the request. The vulnerability exists in the subscription endpoint at `/api/subscription`. The endpoint uses an email parameter as a direct reference to user subscriptions without verifying object ownership. While authentication is required, there is no authorization check to verify if the authenticated user owns the referenced subscription. The issue was fixed in version 1.29.10. Support for arbitrarily presenting an email for update has been deprecated.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2024-52294?

3 open source packages ship an affected version, including khoj.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `khoj` | PyPI | All versions | 1.29.0 |
| `khoj` | PyPI | All versions | 1.29.0 |
| `khoj` | PyPI | All versions | 1.29.0 |

## How do I fix CVE-2024-52294?

Upgrade khoj to 1.29.0 or later.

## Is CVE-2024-52294 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52294 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52294 and fix it if it is affected.

What it is: CVE-2024-52294 is a medium-severity missing authorization vulnerability in khoj-ai khoj, published on 30 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52294 exists.

Affected packages and fixed versions:
- khoj (PyPI): affected all versions; fixed in 1.29.0
- khoj (PyPI): affected all versions; fixed in 1.29.0
- khoj (PyPI): affected all versions; fixed in 1.29.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52294/ (Markdown: https://insights.sbomify.com/CVE-2024-52294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52294
- OSV: https://osv.dev/vulnerability/CVE-2024-52294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52294/
Summaries are generated and may contain mistakes; the official description above is the record.
