# CVE-2024-52299: The PDF viewer macro allows accessing any attachment without access right checks

> Attackers with view rights can access any wiki attachment without proper authorization checks due to flawed key computation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Nov 2024
- **Updated:** 14 Nov 2024
- **Also known as:** GHSA-522m-m242-jr9p

## What is CVE-2024-52299?

CVE-2024-52299 is a high-severity missing authorization vulnerability in xwikisas macro-pdfviewer, published on 13 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

macro-pdfviewer is a PDF Viewer Macro for XWiki using Mozilla pdf.js. Any user with view right on XWiki.PDFViewerService can access any attachment stored in the wiki as the "key" that is passed to prevent this is computed incorrectly, calling skip on the digest stream doesn't update the digest. This is fixed in 2.5.6.

Weakness: CWE-340 (Generation of Predictable Numbers or Identifiers)

## Which versions are affected by CVE-2024-52299?

It affects 1 product.


Products: Xwiki Pdf Viewer Macro.

## How do I fix CVE-2024-52299?

No fix has been published for CVE-2024-52299 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-52299 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52299 exists.

## Other vulnerabilities in xwikisas macro-pdfviewer

- [CVE-2024-52300](https://insights.sbomify.com/CVE-2024-52300/): macro-pdfviewer has a XSS through the width parameter (critical 9.1)
- [CVE-2024-52298](https://insights.sbomify.com/CVE-2024-52298/): macro-pdfviewer's preview in WYSIWYG editor allows accessing any PDF document as the last author (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52299 and fix it if it is affected.

What it is: CVE-2024-52299 is a high-severity missing authorization vulnerability in xwikisas macro-pdfviewer, published on 13 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52299 exists.

Affected product: xwikisas macro-pdfviewer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52299/ (Markdown: https://insights.sbomify.com/CVE-2024-52299/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52299
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52299
- OSV: https://osv.dev/vulnerability/CVE-2024-52299

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52299/
Summaries are generated and may contain mistakes; the official description above is the record.
