# CVE-2024-52303: aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method

> An attacker can exhaust server memory by sending many requests with non-allowed methods when middleware is enabled, causing denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2024
- **Updated:** 19 Nov 2024
- **Also known as:** CLEANSTART-2026-HK21163, CLEANSTART-2026-PZ91840, DEBIAN-CVE-2024-52303, GHSA-27mf-ghqm-j3j8, PYSEC-2026-1096, openSUSE-SU-2024:14556-1

## What is CVE-2024-52303?

CVE-2024-52303 is a high-severity denial of service vulnerability in aio-libs aiohttp, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. In versions starting with 3.10.6 and prior to 3.10.11, a memory leak can occur when a request produces a MatchInfoError. This was caused by adding an entry to a cache on each request, due to the building of each MatchInfoError producing a unique cache entry. An attacker may be able to exhaust the memory resources of a server by sending a substantial number (100,000s to millions) of such requests. Those who use any middlewares with aiohttp.web should upgrade to version 3.10.11 to receive a patch.

Weakness: CWE-772 (Missing Release of Resource after Effective Lifetime)

## Which versions are affected by CVE-2024-52303?

3 open source packages ship an affected version, including aiohttp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | From 3.10.6 | 3.10.11 |
| `aiohttp` | PyPI | From 3.10.6 | 3.10.11 |
| `aiohttp` | PyPI | From 3.10.6 | 3.10.11 |
| `python-aiohttp` | openSUSE:Tumbleweed | All versions | 3.11.9-1.1 |

Products: Aiohttp Aiohttp.

## How do I fix CVE-2024-52303?

Upgrade aiohttp to 3.10.11 or later.

## Is CVE-2024-52303 being exploited?

There is no known exploitation of CVE-2024-52303 in the wild and no public exploit code.

## Other vulnerabilities in aio-libs aiohttp

- [CVE-2025-69223](https://insights.sbomify.com/CVE-2025-69223/): AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb (high 7.5)
- [CVE-2024-30251](https://insights.sbomify.com/CVE-2024-30251/): Denial of service when trying to parse malformed POST requests in aiohttp (high 7.5)
- [CVE-2023-49081](https://insights.sbomify.com/CVE-2023-49081/): aiohttp's ClientSession is vulnerable to CRLF injection via version (high 7.2)
- [CVE-2026-22815](https://insights.sbomify.com/CVE-2026-22815/): AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers (medium 6.9)
- [CVE-2026-54273](https://insights.sbomify.com/CVE-2026-54273/): AIOHTTP: HTTP/1 Pipelined Requests Queue Without Limit (medium 6.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52303 and fix it if it is affected.

What it is: CVE-2024-52303 is a high-severity denial of service vulnerability in aio-libs aiohttp, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52303 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected from 3.10.6; fixed in 3.10.11
- aiohttp (PyPI): affected from 3.10.6; fixed in 3.10.11
- aiohttp (PyPI): affected from 3.10.6; fixed in 3.10.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52303/ (Markdown: https://insights.sbomify.com/CVE-2024-52303/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52303
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52303
- OSV: https://osv.dev/vulnerability/CVE-2024-52303

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52303/
Summaries are generated and may contain mistakes; the official description above is the record.
