# CVE-2024-52304: aiohttp vulnerable to request smuggling due to incorrect parsing of chunk extensions

> Attackers can bypass firewalls or proxies via request smuggling in aiohttp when C extensions are disabled or not installed.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-53229, AZL-53232, CLEANSTART-2026-JK21858, CLEANSTART-2026-KP17501, CLSA-2025-1754007189, DEBIAN-CVE-2024-52304, ECHO-db0b-2011-4735, GHSA-8495-4g3g-x7pr, OESA-2025-1045, OESA-2025-1046, OESA-2025-1047, OESA-2025-1048, PYSEC-2026-1103, RHSA-2024:11574, ROOT-APP-PYPI-CVE-2024-52304, SUSE-SU-2024:4077-1, SUSE-SU-2024:4110-1, UBUNTU-CVE-2024-52304

## What is CVE-2024-52304?

CVE-2024-52304 is a medium-severity vulnerability in aio-libs aiohttp, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. Prior to version 3.10.11, the Python parser parses newlines in chunk extensions incorrectly which can lead to request smuggling vulnerabilities under certain conditions. If a pure Python version of aiohttp is installed (i.e. without the usual C extensions) or `AIOHTTP_NO_EXTENSIONS` is enabled, then an attacker may be able to execute a request smuggling attack to bypass certain firewalls or proxy protections. Version 3.10.11 fixes the issue.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2024-52304?

3 open source packages ship an affected version, including aiohttp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | All versions | 3.10.11 |
| `aiohttp` | PyPI | All versions | 3.10.11 |
| `aiohttp` | PyPI | All versions | 3.10.11 |
| `python-aiohttp` | Red Hat:satellite:6.16::el8 | All versions | 0:3.10.11-1.el8pc |
| `python-aiohttp-debugsource` | Red Hat:satellite:6.16::el8 | All versions | 0:3.10.11-1.el8pc |
| `python3.11-aiohttp` | Red Hat:satellite:6.16::el8 | All versions | 0:3.10.11-1.el8pc |
| `python3.11-aiohttp-debuginfo` | Red Hat:satellite:6.16::el8 | All versions | 0:3.10.11-1.el8pc |
| `python-aiohttp` | Red Hat:satellite:6.16::el9 | All versions | 0:3.10.11-1.el9pc |
| `python-aiohttp-debugsource` | Red Hat:satellite:6.16::el9 | All versions | 0:3.10.11-1.el9pc |
| `python3.11-aiohttp` | Red Hat:satellite:6.16::el9 | All versions | 0:3.10.11-1.el9pc |
| `python3.11-aiohttp-debuginfo` | Red Hat:satellite:6.16::el9 | All versions | 0:3.10.11-1.el9pc |
| `python-aiohttp` | Red Hat:satellite_capsule:6.16::el8 | All versions | 0:3.10.11-1.el8pc |
| `python-aiohttp-debugsource` | Red Hat:satellite_capsule:6.16::el8 | All versions | 0:3.10.11-1.el8pc |
| `python3.11-aiohttp` | Red Hat:satellite_capsule:6.16::el8 | All versions | 0:3.10.11-1.el8pc |
| `python3.11-aiohttp-debuginfo` | Red Hat:satellite_capsule:6.16::el8 | All versions | 0:3.10.11-1.el8pc |
| `python-aiohttp` | Red Hat:satellite_capsule:6.16::el9 | All versions | 0:3.10.11-1.el9pc |
| `python-aiohttp-debugsource` | Red Hat:satellite_capsule:6.16::el9 | All versions | 0:3.10.11-1.el9pc |
| `python3.11-aiohttp` | Red Hat:satellite_capsule:6.16::el9 | All versions | 0:3.10.11-1.el9pc |
| `python3.11-aiohttp-debuginfo` | Red Hat:satellite_capsule:6.16::el9 | All versions | 0:3.10.11-1.el9pc |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP2 | All versions | 3.6.0-150100.3.18.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP3 | All versions | 3.6.0-150100.3.18.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 3.6.0-150100.3.18.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 3.9.3-150400.10.27.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP5 | All versions | 3.6.0-150100.3.18.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP6 | All versions | 3.6.0-150100.3.18.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Python 3 15 SP5 | All versions | 3.9.3-150400.10.27.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 3.9.3-150400.10.27.1 |
| `python-aiohttp` | openSUSE:Leap 15.5 | All versions | 3.6.0-150100.3.18.1 |
| `python-aiohttp` | openSUSE:Leap 15.5 | All versions | 3.9.3-150400.10.27.1 |
| `python-aiohttp` | openSUSE:Leap 15.6 | All versions | 3.9.3-150400.10.27.1 |

Products: Aiohttp Aiohttp.

## How do I fix CVE-2024-52304?

Upgrade aiohttp to 3.10.11 or later.

## Is CVE-2024-52304 being exploited?

There is no known exploitation of CVE-2024-52304 in the wild and no public exploit code.

## Other vulnerabilities in aio-libs aiohttp

- [CVE-2024-52303](https://insights.sbomify.com/CVE-2024-52303/): aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method (high 8.7)
- [CVE-2025-69223](https://insights.sbomify.com/CVE-2025-69223/): AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb (high 7.5)
- [CVE-2024-30251](https://insights.sbomify.com/CVE-2024-30251/): Denial of service when trying to parse malformed POST requests in aiohttp (high 7.5)
- [CVE-2023-49081](https://insights.sbomify.com/CVE-2023-49081/): aiohttp's ClientSession is vulnerable to CRLF injection via version (high 7.2)
- [CVE-2026-22815](https://insights.sbomify.com/CVE-2026-22815/): AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52304 and fix it if it is affected.

What it is: CVE-2024-52304 is a medium-severity vulnerability in aio-libs aiohttp, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52304 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected all versions; fixed in 3.10.11
- aiohttp (PyPI): affected all versions; fixed in 3.10.11
- aiohttp (PyPI): affected all versions; fixed in 3.10.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52304/ (Markdown: https://insights.sbomify.com/CVE-2024-52304/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52304
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52304
- OSV: https://osv.dev/vulnerability/CVE-2024-52304

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52304/
Summaries are generated and may contain mistakes; the official description above is the record.
