# CVE-2024-52305: UnoPim Stored XSS : Cookie hijacking through Create User function

> Attackers can steal session cookies via stored XSS in the user profile image upload feature, potentially leading to account takeover.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Nov 2024
- **Updated:** 13 Nov 2024
- **Also known as:** GHSA-cgr4-c233-h733

## What is CVE-2024-52305?

CVE-2024-52305 is a medium-severity cross-site scripting vulnerability in unopim, published on 13 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

UnoPim is an open-source Product Information Management (PIM) system built on the Laravel framework. A vulnerability exists in the Create User process, allowing the creation of a new admin account with an option to upload a profile image. An attacker can upload a malicious SVG file containing an embedded script. When the profile image is accessed, the embedded script executes, leading to the potential theft of session cookies. This vulnerability is fixed in 0.1.5.

Weakness: CWE-692 (Incomplete Denylist to Cross-Site Scripting), CWE-616 (Incomplete Identification of Uploaded File Variables (PHP))

## Which versions are affected by CVE-2024-52305?

2 open source packages ship an affected version, including unopim/unopim. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `unopim/unopim` | Packagist | All versions | 0.1.5 |
| `unopim/unopim` | Packagist | All versions | 0.1.5 |

Products: Webkul Unopim.

## How do I fix CVE-2024-52305?

Upgrade unopim/unopim to 0.1.5 or later.

## Is CVE-2024-52305 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52305 exists.

## Other vulnerabilities in unopim

- [CVE-2025-55741](https://insights.sbomify.com/CVE-2025-55741/): unopim/unopim allows unauthorized product deletion via mass-delete endpoint (high 8.1)
- [CVE-2025-55742](https://insights.sbomify.com/CVE-2025-55742/): UnoPim Stored XSS via SVG MIME/Sanitizer Bypass (high 8.0)
- [CVE-2025-55743](https://insights.sbomify.com/CVE-2025-55743/): UnoPim vulnerable to remote code execution through Arbitrary File upload (high 7.3)
- [CVE-2025-55744](https://insights.sbomify.com/CVE-2025-55744/): UnoPim vulnerable to CSRF on Product edit feature and creation of other types (medium 6.9)
- [CVE-2024-50637](https://insights.sbomify.com/CVE-2024-50637/): UnoPim Cross-site Scripting vulnerability (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52305 and fix it if it is affected.

What it is: CVE-2024-52305 is a medium-severity cross-site scripting vulnerability in unopim, published on 13 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-52305 exists.

Affected packages and fixed versions:
- unopim/unopim (Packagist): affected all versions; fixed in 0.1.5
- unopim/unopim (Packagist): affected all versions; fixed in 0.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52305/ (Markdown: https://insights.sbomify.com/CVE-2024-52305/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52305
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52305
- OSV: https://osv.dev/vulnerability/CVE-2024-52305

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52305/
Summaries are generated and may contain mistakes; the official description above is the record.
