# CVE-2024-52306: FileManager Deserialization of Untrusted Data

> Attackers can achieve remote code execution via unsafe deserialization of the mimes parameter in the Laravel Backpack FileManager package.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Nov 2024
- **Updated:** 13 Nov 2024
- **Also known as:** GHSA-8237-957h-h2c2

## What is CVE-2024-52306?

CVE-2024-52306 is a high-severity unsafe deserialization vulnerability in Laravel-Backpack FileManager, published on 13 Nov 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

FileManager provides a Backpack admin interface for files and folder. Prior to 3.0.9, deserialization of untrusted data from the mimes parameter could lead to remote code execution. This vulnerability is fixed in 3.0.9.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-52306?

4 open source packages ship an affected version, including backpack/filemanager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `backpack/filemanager` | Packagist | All versions | 2.0.2 |
| `backpack/filemanager` | Packagist | All versions | 2.0.2 |
| `backpack/filemanager` | Packagist | From 3.0.0 | 3.0.9 |
| `backpack/filemanager` | Packagist | From 3.0.0 | 3.0.9 |

Products: Backpackforlaravel Filemanager.

## How do I fix CVE-2024-52306?

Upgrade backpack/filemanager to a fixed version for your release line: 2.0.2 or 3.0.9.

## Is CVE-2024-52306 being exploited?

There is no known exploitation of CVE-2024-52306 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52306 and fix it if it is affected.

What it is: CVE-2024-52306 is a high-severity unsafe deserialization vulnerability in Laravel-Backpack FileManager, published on 13 Nov 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-52306 in the wild and no public exploit code.

Affected packages and fixed versions:
- backpack/filemanager (Packagist): affected all versions; fixed in 2.0.2
- backpack/filemanager (Packagist): affected all versions; fixed in 2.0.2
- backpack/filemanager (Packagist): affected from 3.0.0; fixed in 3.0.9
- backpack/filemanager (Packagist): affected from 3.0.0; fixed in 3.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52306/ (Markdown: https://insights.sbomify.com/CVE-2024-52306/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52306
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52306
- OSV: https://osv.dev/vulnerability/CVE-2024-52306

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52306/
Summaries are generated and may contain mistakes; the official description above is the record.
