CVE-2024-52316 Apache Tomcat: Authentication bypass when using Jakarta Authentication API
Attackers can bypass authentication in Apache Tomcat if a custom Jakarta Authentication component throws an exception without setting an HTTP failure status.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-52316?
CVE-2024-52316 is a critical authentication bypass vulnerability in Apache Tomcat, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Unchecked Error Condition vulnerability in Apache Tomcat. If Tomcat is configured to use a custom Jakarta Authentication (formerly JASPIC) ServerAuthContext component which may throw an exception during the authentication process without explicitly setting an HTTP status to indicate failure, the authentication may not fail, allowing the user to bypass the authentication process. There are no known Jakarta Authentication components that behave in this way.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M26, from 10.1.0-M1 through 10.1.30, from 9.0.0-M1 through 9.0.95.
The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fix the issue.
Which versions are affected by CVE-2024-52316?
7 open source packages ship an affected version, including org.apache.tomcat:tomcat-catalina and tomcat. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat-catalina Maven | All versions | 9.0.96 |
org.apache.tomcat:tomcat-catalina Maven | All versions | 9.0.96 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.30 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.30 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.1 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.1 |
1 more packages
tomcat Bitnami | From 9.0.0 | 9.0.96, 10.1.31 |
Linux distribution packages (24)
tomcat SUSE:Enterprise Storage 7.1 | All versions | 9.0.97-150200.71.1 |
tomcat SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 9.0.97-150200.71.1 |
tomcat SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 9.0.97-150200.71.1 |
tomcat SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 9.0.97-150200.71.1 |
tomcat SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 9.0.97-150200.71.1 |
tomcat SUSE:Linux Enterprise Module for Web and Scripting 15 SP5 | All versions | 9.0.97-150200.71.1 |
tomcat10 SUSE:Linux Enterprise Module for Web and Scripting 15 SP5 | All versions | 10.1.33-150200.5.28.1 |
tomcat SUSE:Linux Enterprise Module for Web and Scripting 15 SP6 | All versions | 9.0.97-150200.71.1 |
tomcat10 SUSE:Linux Enterprise Module for Web and Scripting 15 SP6 | All versions | 10.1.33-150200.5.28.1 |
tomcat SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 9.0.36-3.133.1 |
tomcat SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 9.0.97-150200.71.1 |
tomcat SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 9.0.97-150200.71.1 |
tomcat SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 9.0.97-150200.71.1 |
tomcat SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 9.0.36-3.133.1 |
tomcat SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 9.0.97-150200.71.1 |
tomcat SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 9.0.97-150200.71.1 |
tomcat SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 9.0.97-150200.71.1 |
tomcat SUSE:Manager Server 4.3 | All versions | 9.0.97-150200.71.1 |
tomcat openSUSE:Leap 15.5 | All versions | 9.0.97-150200.71.1 |
tomcat10 openSUSE:Leap 15.5 | All versions | 10.1.33-150200.5.28.1 |
tomcat openSUSE:Leap 15.6 | All versions | 9.0.97-150200.71.1 |
tomcat10 openSUSE:Leap 15.6 | All versions | 10.1.33-150200.5.28.1 |
tomcat openSUSE:Tumbleweed | All versions | 9.0.97-1.1 |
tomcat10 openSUSE:Tumbleweed | All versions | 10.1.33-1.1 |
Products include Apache Tomcat, Debian Debian Linux.
How do I fix CVE-2024-52316?
Upgrade org.apache.tomcat:tomcat-catalina to a fixed version for your release line: 9.0.96, 10.1.30 or 11.0.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2024-52316 being exploited?
There is no known exploitation of CVE-2024-52316 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2024-52316, DEBIAN-CVE-2024-52316, GHSA-xcpr-7mr4-h4xq, ROOT-APP-MAVEN-CVE-2024-52316, SUSE-SU-2024:4075-1, SUSE-SU-2024:4105-1 and 4 more.