CVE-2024-52317 Apache Tomcat: Request/response mix-up with HTTP/2
Incorrect object recycling in Apache Tomcat HTTP/2 handling allows attackers to view other users' request or response data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-52317?
CVE-2024-52317 is a medium-severity vulnerability in Apache Tomcat, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Incorrect object re-cycling and re-use vulnerability in Apache Tomcat. Incorrect recycling of the request and response used by HTTP/2 requests could lead to request and/or response mix-up between users.
This issue affects Apache Tomcat: from 11.0.0-M23 through 11.0.0-M26, from 10.1.27 through 10.1.30, from 9.0.92 through 9.0.95.
Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fixes the issue.
Weakness: CWE-326
Which versions are affected by CVE-2024-52317?
13 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-coyote. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.27 | 10.1.31 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.27 | 10.1.31 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M23 | 11.0.0 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M23 | 11.0.0 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.92 | 9.0.96 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.92 | 9.0.96 |
7 more packages
tomcat Bitnami | From 9.0.92 | 9.0.96, 10.1.31, 11.0.9 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.27 | 10.1.31 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.27 | 10.1.31 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M23 | 11.0.0 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M23 | 11.0.0 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.92 | 9.0.96 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.92 | 9.0.96 |
Linux distribution packages (2)
tomcat openSUSE:Tumbleweed | All versions | 9.0.102-1.1 |
tomcat10 openSUSE:Tumbleweed | All versions | 10.1.39-1.1 |
Products include Apache Tomcat.
How do I fix CVE-2024-52317?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.31, 11.0.0 or 9.0.96.
Is CVE-2024-52317 being exploited?
There is no known exploitation of CVE-2024-52317 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2024-52317, DEBIAN-CVE-2024-52317, GHSA-qvf5-hvjx-wm27, ROOT-APP-MAVEN-CVE-2024-52317, UBUNTU-CVE-2024-52317, openSUSE-SU-2025:14911-1 and 1 more.