# CVE-2024-52317: Apache Tomcat: Request/response mix-up with HTTP/2

> Incorrect object recycling in Apache Tomcat HTTP/2 handling allows attackers to view other users' request or response data.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2024
- **Updated:** 24 Jan 2025
- **Also known as:** BIT-tomcat-2024-52317, DEBIAN-CVE-2024-52317, GHSA-qvf5-hvjx-wm27, ROOT-APP-MAVEN-CVE-2024-52317, UBUNTU-CVE-2024-52317, openSUSE-SU-2025:14911-1, openSUSE-SU-2025:14915-1

## What is CVE-2024-52317?

CVE-2024-52317 is a medium-severity vulnerability in Apache Tomcat, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Incorrect object re-cycling and re-use vulnerability in Apache Tomcat. Incorrect recycling of the request and response used by HTTP/2 requests 
could lead to request and/or response mix-up between users.

This issue affects Apache Tomcat: from 11.0.0-M23 through 11.0.0-M26, from 10.1.27 through 10.1.30, from 9.0.92 through 9.0.95.

Users are recommended to upgrade to version 11.0.0, 10.1.31 or 9.0.96, which fixes the issue.

Weakness: CWE-326 (Inadequate Encryption Strength)

## Which versions are affected by CVE-2024-52317?

13 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-coyote. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.27 | 10.1.31 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.27 | 10.1.31 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M23 | 11.0.0 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M23 | 11.0.0 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.92 | 9.0.96 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.92 | 9.0.96 |
| `tomcat` | Bitnami | From 9.0.92 | 9.0.96, 10.1.31, 11.0.9 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.27 | 10.1.31 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.27 | 10.1.31 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.0-M23 | 11.0.0 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.0-M23 | 11.0.0 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.92 | 9.0.96 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.92 | 9.0.96 |
| `tomcat` | openSUSE:Tumbleweed | All versions | 9.0.102-1.1 |
| `tomcat10` | openSUSE:Tumbleweed | All versions | 10.1.39-1.1 |

Products: Apache Tomcat.

## How do I fix CVE-2024-52317?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.31, 11.0.0 or 9.0.96.

## Is CVE-2024-52317 being exploited?

There is no known exploitation of CVE-2024-52317 in the wild and no public exploit code.

Public exploit code:

- CVE-2024-52317 - Apache Tomcat HTTP/2 Data Leakage Vulnerability (github_poc): https://github.com/TAM-K592/CVE-2024-52317

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52317 and fix it if it is affected.

What it is: CVE-2024-52317 is a medium-severity vulnerability in Apache Tomcat, published on 18 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52317 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.27; fixed in 10.1.31
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.27; fixed in 10.1.31
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M23; fixed in 11.0.0
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M23; fixed in 11.0.0
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.92; fixed in 9.0.96
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.92; fixed in 9.0.96
- tomcat (Bitnami): affected from 9.0.92; fixed in 9.0.96, 10.1.31, 11.0.9
- org.apache.tomcat:tomcat-coyote (Maven): affected from 10.1.27; fixed in 10.1.31
- org.apache.tomcat:tomcat-coyote (Maven): affected from 10.1.27; fixed in 10.1.31
- org.apache.tomcat:tomcat-coyote (Maven): affected from 11.0.0-M23; fixed in 11.0.0
- org.apache.tomcat:tomcat-coyote (Maven): affected from 11.0.0-M23; fixed in 11.0.0
- org.apache.tomcat:tomcat-coyote (Maven): affected from 9.0.92; fixed in 9.0.96

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52317/ (Markdown: https://insights.sbomify.com/CVE-2024-52317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52317
- OSV: https://osv.dev/vulnerability/CVE-2024-52317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52317/
Summaries are generated and may contain mistakes; the official description above is the record.
