{"answers":{"affected":"1 open source package ship an affected version, including pyarrow. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-52338 in the wild and no public exploit code.","fix":"Upgrade pyarrow to 17.0.0 or later.","what":"CVE-2024-52338 is a critical unsafe deserialization vulnerability in Apache Arrow R package, published on 28 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-52338 and fix it if it is affected.\n\nWhat it is: CVE-2024-52338 is a critical unsafe deserialization vulnerability in Apache Arrow R package, published on 28 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-52338 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pyarrow (PyPI): affected from 4.0.0; fixed in 17.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-52338/ (Markdown: https://insights.sbomify.com/CVE-2024-52338/index.md)","id":"CVE-2024-52338","markdown":"https://insights.sbomify.com/CVE-2024-52338/index.md","name":"CVE-2024-52338","record":{"aliases":["AZL-53423","AZL-53471","GHSA-m5xw-hwxw-fq3j","JLSEC-2026-804","PYSEC-2024-161"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Arrow R package","requires_auth":"none","summary":"Attackers can execute arbitrary code by tricking users into loading malicious Arrow IPC or Parquet files in the Apache Arrow R package.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"arrow","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Deserialization of untrusted data in IPC and Parquet readers in the Apache Arrow R package versions 4.0.0 through 16.1.0 allows arbitrary code execution. An application is vulnerable if it \nreads Arrow IPC, Feather or Parquet data from untrusted sources (for \nexample, user-supplied input files). This vulnerability only affects the arrow R package, not other Apache Arrow \nimplementations or bindings unless those bindings are specifically used via the R package (for example, an R application that embeds a Python interpreter and uses PyArrow to read files from untrusted sources is still vulnerable if the arrow R package is an affected version). It is recommended that users of the arrow R package upgrade to 17.0.0 or later. Similarly, it\n is recommended that downstream libraries upgrade their dependency \nrequirements to arrow 17.0.0 or later. If using an affected\nversion of the package, untrusted data can read into a Table and its internal to_data_frame() method can be used as a workaround (e.g., read_parquet(..., as_data_frame = FALSE)$to_data_frame()).\n\nThis issue affects the Apache Arrow R package: from 4.0.0 through 16.1.0.\n\nUsers are recommended to upgrade to version 17.0.0, which fixes the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Arrow R package: Arbitrary code execution when loading a malicious data file","id":"CVE-2024-52338","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2024"},"n_packages":1,"n_references":2,"next":{"headline":"WordPress Mage Front End Forms plugin \u003c= 1.1.4 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-52339"},"packages":[{"ecosystem":"PyPI","fixed":["17.0.0"],"introduced":["4.0.0"],"last_affected":[],"package":"pyarrow","purl":"pkg:pypi/pyarrow","source":"PYSEC-2024-161"}],"prev":{"headline":"Tuned: improper sanitization of `instance_name` parameter of the `instance_create()` method","id":"CVE-2024-52337"},"products":["Apache Arrow R package"],"published":"2024-11-28","related":[{"cvss_score":7.5,"headline":"Apache Arrow Rust Object Store: AWS WebIdentityToken exposure in log files","id":"CVE-2024-41178","kev_date_added":null,"published":"2024-07-23"},{"cvss_score":7.5,"headline":"Missing Initialization of Resource in Apache Arrow","id":"CVE-2019-12408","kev_date_added":null,"published":"2019-11-08"},{"cvss_score":7.5,"headline":"Missing Initialization of Resource in Apache Arrow","id":"CVE-2019-12410","kev_date_added":null,"published":"2019-11-08"},{"cvss_score":7,"headline":"Apache Arrow: Potential use-after-free when reading IPC file with pre-buffering","id":"CVE-2026-25087","kev_date_added":null,"published":"2026-02-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-29","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary code by tricking users into loading malicious Arrow IPC or Parquet files in the Apache Arrow R package.","url":"https://insights.sbomify.com/CVE-2024-52338/"}