CVE-2024-52505 matrix-appservice-irc allows IRC Command injection in provisioning API

Medium 5.4 Published Updated

Attackers can execute arbitrary IRC commands via the provisioning API, requiring an upgrade to the patched version.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-52505?

CVE-2024-52505 is a medium-severity command injection vulnerability in matrix-org matrix-appservice-irc, published on 14 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

matrix-appservice-irc is a Node.js IRC bridge for the Matrix messaging protocol. The provisioning API of the matrix-appservice-irc bridge up to version 3.0.2 contains a vulnerability which can lead to arbitrary IRC command execution as the bridge IRC bot. The vulnerability has been patched in matrix-appservice-irc version 3.0.3.

Weakness: CWE-147

Which versions are affected by CVE-2024-52505?

How do I fix CVE-2024-52505?

No fix has been published for CVE-2024-52505 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2024-52505 being exploited?

There is no known exploitation of CVE-2024-52505 in the wild and no public exploit code.

Sources

Also known as GHSA-c3hj-hg7p-rrq5.

Is CVE-2024-52505 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free