# CVE-2024-52505: matrix-appservice-irc allows IRC Command injection in provisioning API

> Attackers can execute arbitrary IRC commands via the provisioning API, requiring an upgrade to the patched version.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Nov 2024
- **Updated:** 14 Nov 2024
- **Also known as:** GHSA-c3hj-hg7p-rrq5

## What is CVE-2024-52505?

CVE-2024-52505 is a medium-severity command injection vulnerability in matrix-org matrix-appservice-irc, published on 14 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

matrix-appservice-irc is a Node.js IRC bridge for the Matrix messaging protocol. The provisioning API of the matrix-appservice-irc bridge up to version 3.0.2 contains a vulnerability which can lead to arbitrary IRC command execution as the bridge IRC bot. The vulnerability has been patched in matrix-appservice-irc version 3.0.3.

Weakness: CWE-147 (Improper Neutralization of Input Terminators)

## Which versions are affected by CVE-2024-52505?


## How do I fix CVE-2024-52505?

No fix has been published for CVE-2024-52505 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-52505 being exploited?

There is no known exploitation of CVE-2024-52505 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52505 and fix it if it is affected.

What it is: CVE-2024-52505 is a medium-severity command injection vulnerability in matrix-org matrix-appservice-irc, published on 14 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52505 in the wild and no public exploit code.

Affected product: matrix-org matrix-appservice-irc. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52505/ (Markdown: https://insights.sbomify.com/CVE-2024-52505/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52505
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52505
- OSV: https://osv.dev/vulnerability/CVE-2024-52505

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52505/
Summaries are generated and may contain mistakes; the official description above is the record.
