{"answers":{"affected":"3 open source packages ship an affected version, including giskard.","exploited":"There is no known exploitation of CVE-2024-52524 in the wild and no public exploit code.","fix":"Upgrade giskard to 2.15.5 or later.","what":"CVE-2024-52524 is a medium-severity denial of service vulnerability in Giskard-AI giskard, published on 14 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-52524 and fix it if it is affected.\n\nWhat it is: CVE-2024-52524 is a medium-severity denial of service vulnerability in Giskard-AI giskard, published on 14 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-52524 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- giskard (PyPI): affected all versions; fixed in 2.15.5\n- giskard (PyPI): affected all versions; fixed in 2.15.5\n- giskard (PyPI): affected all versions; fixed in 2.15.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-52524/ (Markdown: https://insights.sbomify.com/CVE-2024-52524/index.md)","id":"CVE-2024-52524","markdown":"https://insights.sbomify.com/CVE-2024-52524/index.md","name":"CVE-2024-52524","record":{"aliases":["GHSA-pjwm-cr36-mwv3","PYSEC-2026-1403"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"AI evaluation framework","requires_auth":"none","summary":"Attackers can cause denial of service in Giskard AI framework by submitting datasets with specific text patterns that trigger exponential regex evaluation times.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/U:Clear","version":"4.0"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"Giskard is an evaluation and testing framework for AI systems. A Remote Code Execution (ReDoS) vulnerability was discovered in Giskard component by the GitHub Security Lab team. When processing datasets with specific text patterns with Giskard detectors, this vulnerability could trigger exponential regex evaluation times, potentially leading to denial of service. Giskard versions prior to 2.15.5 are affected.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ReDoS in Giskard Scan text perturbation","id":"CVE-2024-52524","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Nextcloud Server User password is available in memory of the PHP process","id":"CVE-2024-52525"},"packages":[{"ecosystem":"PyPI","fixed":["2.15.5"],"introduced":["0"],"last_affected":[],"package":"giskard","purl":null,"source":"GHSA-pjwm-cr36-mwv3"},{"ecosystem":"PyPI","fixed":["2.15.5"],"introduced":["0"],"last_affected":[],"package":"giskard","purl":"pkg:pypi/giskard","source":"GHSA-pjwm-cr36-mwv3"},{"ecosystem":"PyPI","fixed":["2.15.5"],"introduced":["0"],"last_affected":[],"package":"giskard","purl":"pkg:pypi/giskard","source":"PYSEC-2026-1403"}],"prev":{"headline":"Nextcloud Server Custom defined credentials of external storages are sent back to the frontend","id":"CVE-2024-52523"},"products":["giskard"],"published":"2024-11-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-21","vendors":["Giskard-AI"]},"summary":"Attackers can cause denial of service in Giskard AI framework by submitting datasets with specific text patterns that trigger exponential regex evaluation times.","url":"https://insights.sbomify.com/CVE-2024-52524/"}