# CVE-2024-52524: ReDoS in Giskard Scan text perturbation

> Attackers can cause denial of service in Giskard AI framework by submitting datasets with specific text patterns that trigger exponential regex evaluation times.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Nov 2024
- **Updated:** 21 Nov 2024
- **Also known as:** GHSA-pjwm-cr36-mwv3, PYSEC-2026-1403

## What is CVE-2024-52524?

CVE-2024-52524 is a medium-severity denial of service vulnerability in Giskard-AI giskard, published on 14 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Giskard is an evaluation and testing framework for AI systems. A Remote Code Execution (ReDoS) vulnerability was discovered in Giskard component by the GitHub Security Lab team. When processing datasets with specific text patterns with Giskard detectors, this vulnerability could trigger exponential regex evaluation times, potentially leading to denial of service. Giskard versions prior to 2.15.5 are affected.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2024-52524?

3 open source packages ship an affected version, including giskard.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `giskard` | PyPI | All versions | 2.15.5 |
| `giskard` | PyPI | All versions | 2.15.5 |
| `giskard` | PyPI | All versions | 2.15.5 |

## How do I fix CVE-2024-52524?

Upgrade giskard to 2.15.5 or later.

## Is CVE-2024-52524 being exploited?

There is no known exploitation of CVE-2024-52524 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52524 and fix it if it is affected.

What it is: CVE-2024-52524 is a medium-severity denial of service vulnerability in Giskard-AI giskard, published on 14 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-52524 in the wild and no public exploit code.

Affected packages and fixed versions:
- giskard (PyPI): affected all versions; fixed in 2.15.5
- giskard (PyPI): affected all versions; fixed in 2.15.5
- giskard (PyPI): affected all versions; fixed in 2.15.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52524/ (Markdown: https://insights.sbomify.com/CVE-2024-52524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52524
- OSV: https://osv.dev/vulnerability/CVE-2024-52524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52524/
Summaries are generated and may contain mistakes; the official description above is the record.
