# CVE-2024-52529: Layer 7 policy enforcement may not occur in policies with wildcarded port ranges in Cilium


- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Nov 2024
- **Updated:** 26 Nov 2024
- **Also known as:** BIT-cilium-2024-52529, BIT-cilium-operator-2024-52529, BIT-hubble-relay-2024-52529, GHSA-xg58-75qf-9r67, GO-2024-3290

## What is CVE-2024-52529?

CVE-2024-52529 is a medium-severity vulnerability in cilium, published on 25 Nov 2024. 

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. For users with the following configuration: 1. An allow policy that selects a Layer 3 destination and a port range `AND` 2. A Layer 7 allow policy that selects a specific port within the first policy's range the Layer 7 enforcement would not occur for the traffic selected by the Layer 7 policy. This issue only affects users who use Cilium's port range functionality, which was introduced in Cilium v1.16. This issue is patched in PR #35150. This issue affects Cilium v1.16 between v1.16.0 and v1.16.3 inclusive. This issue is patched in Cilium v1.16.4. Users are advised to upgrade. Users with network policies that match the pattern described above can work around the issue by rewriting any policies that use port ranges to individually specify the ports permitted for traffic.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2024-52529?

6 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | From 1.16.0 | 1.16.4 |
| `github.com/cilium/cilium` | Go | From 1.16.0 | 1.16.4 |
| `github.com/cilium/cilium` | Go | From 1.16.0 | 1.16.4 |
| `cilium` | Bitnami | From 1.16.0 | 1.16.4 |
| `cilium-operator` | Bitnami | From 1.16.0 | 1.16.4 |
| `hubble-relay` | Bitnami | From 1.16.0 | 1.16.4 |

Products: Cilium Cilium.

## How do I fix CVE-2024-52529?

Upgrade github.com/cilium/cilium to 1.16.4 or later.

## Is CVE-2024-52529 being exploited?

There is no known exploitation of CVE-2024-52529 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52529 and fix it if it is affected.

What it is: CVE-2024-52529 is a medium-severity vulnerability in cilium, published on 25 Nov 2024. 
Exploitation: There is no known exploitation of CVE-2024-52529 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected from 1.16.0; fixed in 1.16.4
- github.com/cilium/cilium (Go): affected from 1.16.0; fixed in 1.16.4
- github.com/cilium/cilium (Go): affected from 1.16.0; fixed in 1.16.4
- cilium (Bitnami): affected from 1.16.0; fixed in 1.16.4
- cilium-operator (Bitnami): affected from 1.16.0; fixed in 1.16.4
- hubble-relay (Bitnami): affected from 1.16.0; fixed in 1.16.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52529/ (Markdown: https://insights.sbomify.com/CVE-2024-52529/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52529
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52529
- OSV: https://osv.dev/vulnerability/CVE-2024-52529

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52529/
Summaries are generated and may contain mistakes; the official description above is the record.
