# CVE-2024-52551: Restarting a run with revoked script approval allowed by Jenkins Pipeline: Declarative Plugin

> Attackers with build permissions can restart builds using unapproved scripts, bypassing security controls and potentially executing malicious code.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Nov 2024
- **Updated:** 14 Nov 2024
- **Also known as:** GHSA-p2qq-c693-q53w

## What is CVE-2024-52551?

CVE-2024-52551 is a high-severity missing authorization vulnerability in Jenkins Pipeline: Declarative Plugin, published on 13 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Pipeline: Declarative Plugin 2.2214.vb_b_34b_2ea_9b_83 and earlier does not check whether the main (Jenkinsfile) script used to restart a build from a specific stage is approved, allowing attackers with Item/Build permission to restart a previous build whose (Jenkinsfile) script is no longer approved.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2024-52551?

2 open source packages ship an affected version, including org.jenkinsci.plugins:pipeline-model-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkinsci.plugins:pipeline-model-parent` | Maven | All versions | 2.2218.v56d0cda |
| `org.jenkinsci.plugins:pipeline-model-parent` | Maven | All versions | 2.2218.v56d0cda |

Products: Jenkins Pipeline\.

## How do I fix CVE-2024-52551?

Upgrade org.jenkinsci.plugins:pipeline-model-parent to 2.2218.v56d0cda or later.

## Is CVE-2024-52551 being exploited?

There is no known exploitation of CVE-2024-52551 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Pipeline: Declarative Plugin

- [CVE-2019-1003030](https://insights.sbomify.com/CVE-2019-1003030/): Jenkins Matrix Project Plugin Remote Code Execution (critical 9.9, exploited in the wild)
- [CVE-2022-43402](https://insights.sbomify.com/CVE-2022-43402/): Jenkins Pipeline: Groovy Plugin allows sandbox protection bypass and arbitrary code execution (critical 9.9)
- [CVE-2019-1003041](https://insights.sbomify.com/CVE-2019-1003041/): Sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin (critical 9.8)
- [CVE-2022-43407](https://insights.sbomify.com/CVE-2022-43407/): CSRF protection for any URL can be bypassed in Jenkins Pipeline: Input Step Plugin (high 8.8)
- [CVE-2022-25173](https://insights.sbomify.com/CVE-2022-25173/): Improper Neutralization of Special Elements used in an OS Command in Jenkins Pipeline: Groovy Plugin (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-52551 and fix it if it is affected.

What it is: CVE-2024-52551 is a high-severity missing authorization vulnerability in Jenkins Pipeline: Declarative Plugin, published on 13 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-52551 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkinsci.plugins:pipeline-model-parent (Maven): affected all versions; fixed in 2.2218.v56d0cda
- org.jenkinsci.plugins:pipeline-model-parent (Maven): affected all versions; fixed in 2.2218.v56d0cda

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-52551/ (Markdown: https://insights.sbomify.com/CVE-2024-52551/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-52551
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-52551
- OSV: https://osv.dev/vulnerability/CVE-2024-52551

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-52551/
Summaries are generated and may contain mistakes; the official description above is the record.
